SKR Mini E3 V3.0 MCU problems

I’ve spent the last two days trying to configure Mainsail and octoprint klipper on my raspberry pi 4 and my ender 3 with skr mini e3 v3 with bltouch and tft35 touch screen. ive gone thru each step of the appropriate setups and install. When i get to flashing the Klipper.bin, changing it to firmware.bin, and flash it to my printer it the screen goes blank and only shows the LCD12864 on the screen, and nothing else happens. when I do the make menuconfig this is my setup

which is what BTT specifies in the printer config file for btt skr mini e3 v3 firmware klipper on github. when i do the /dev/serial/by-id/* i get this back as a response /dev/serial/by-id/usb-klipper_stm32g0b1xx_0E0019000950414733303120-if00 and i placed that in the MCU of the printer.cfg

serial: /dev/serial/by-id/usb-klipper_stm32g0b1xx_0E0019000950414733303120-if00
#serial: /dev/ttyAMA0
restart_method: command
but i keep getting the MCU unable to connect error in both mainsail and octoprint klipper.

I am at a loss of what else to do nothing that i flash seems to work. The only flash that works for me is setting the mainboard back to marlin 2.0 bug fix. Ive looked through tons of posts on this and have not found an answer. i hope someone can please help me. I ultimately want to use mainsail as my interface for the raspberry and my printer.

Post your klippy.log file please

klippy.log (9.7 KB)
i just noticed looking through that file that it doesnt even show the /dev/serial/by-id number but i have it inside my printer.cfg. i dont understand why its not showing in the log
printer.cfg (8.1 KB)

Check your klippy.log file. Here you will see what config items Klipper has read.
This is not a complete configuration. Maybe you are editing the wrong file.
As of your current setup Klipper is expecting the config in /home/pi/klipper_config/printer.cfg

that was what the printer configs they gave from from the instructions on Klipper installation. i am not sure what else to put in there i dont have any uncompiled config files for my printer setup.
I tried compiling marlin firmware before with vscode platformio when i had installed the Skr mini e3 v1.2 and the TFT3.5 v3 touch screen (replaced screen because the factory one got smashed so i dont have the original screen), but i could not get anything to compile correctly and i finally found someone who had pre compiled firmware and that worked for my printer. but i dont have any of the source files from that firmware. Im not new to 3d printers and the software, but i am a noob when it comes to compiling and the firmware precompiled setups.
Sorry if im frustrating you in any way. Im just very confused because i did what the instructions said and its probably not even close to what i actually need.

Well after playing with it a bit more, i finally got it to work, i rebuilt everything from scratch, for mainsail. i rebuilt the menu config, copied the ls /dev/serial/by-id/* and pasted it in the printer.cfg in mainsail maching printer.cfg and saved and restarted and it came on. i think i some how messed up the serial numbers and the one on mainsail was looking for one and i had another on in the putty, and some how they didnt match until i rebuilt everything. It was probably mostly my nooby mistake, but things are working great now and ty for your help.

FTR, I had this same exact problem. Originally I was receiving this:

I was able to solve mine by restarting the machine w/o the sdCard inserted. Once I had rebooted, I then reconnected to the rPi 4 through puTTy and reran
‘ls /dev/serial/by-id/*’
this gave an entirely different response string:

I added them both and commented out the original response and restarted the firmware. I’ve ssh’d into my other two rPi’s and neither return that …4D003… number. Not sure where it came from…

I went to the BTT website and copied the Klipper.usb.bin file to my sdcard and flashed the board with it
It is working fine with that