MCU not responding to anything

Basic Information:

Printer Model: Ender 3
MCU / Printerboard: SKR mini e3 v2
klippy.log

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

Hey guys, so I have been trying to get my printer running klipper for about 2 weeks now and am scared I may have messed it all up. I was running mainsail with my RPI 3b but kept getting mcu errors. Found out it was because I wasn’t successfully uploading the klipper firmware to my mcu, which was the original mcu that came out in 2018, so I decided to upgrade to the mini e3 v2. I installed the mcu and it seemed to be working fine, screen worked and I had all settings available, still no mcu connection on mainsail. I tried flashing klipper firmware.bin that i built in kiauh, didnt seem to upload. searched around and figured I needed to download the bootloader for the SKR. followed a guide I found and when I powered on with the sd card the printer turned on and the screen was blank. I let it sit awhile since most videos had the same thing happened. Now the screen has been stuck like that every boot, blank glowing blue, no words. I decided to restart completely, this time I used fluidd. Only problem is I still cannot connect MCU and the screen is still blank, and when i try to flash the firmware with kiauh, it says no mcu detected/connected. when i put ls /dev/serial/by-id/* I get ls: cannot access ‘/dev/serial/by-id/*’: No such file or directory. So since I tried uploading the bootloader it seems my mcu hasnt responded. I still get lights on the board and the screen lights up but thats it. Any ideas? PLEASE HELP ME

klippy (5).log (109.6 KB)

Check your log and your [extruder] section. It is not fully configured.

Refer to klipper/config/printer-creality-ender3-2018.cfg at 6ce6fbbce07605010c0d4fa8eaa0ebcde01e53db · Klipper3d/klipper · GitHub

you think that is affecting the mcu connection? and the screen?

The last error in your log is related to your bed.

configparser.Error: Option 'control' in section 'heater_bed' must be specified

You need to specify pid or watermark for the heater control.

control: pid

FYI the screen will remain blank until Klipper successfully starts.

would this fix my mcu not being detected?

The last restart in your log has errors for your bed, and as Sineos notes you also have problems with your extruder. You need to fix those and post a new log file before any further diagnosis can happen.

hello, i am having the same issues and am a complete noob. what do you mean get the correct path? i unplugged the board and used the sudo dmesg but a lot of information pops up. i did have the bullseye bug but i believe it was remedied after following the steps you have posted on a forum. i still get
Failed to flash to /dev/ttyACM1: Unable to find serial ‘by-path’ folder

If the device is already in bootloader mode it can be flashed with the
following command:
make flash FLASH_DEVICE=1eaf:0003
OR
make flash FLASH_DEVICE=1209:beba

If attempting to flash via 3.3V serial, then use:
make serialflash FLASH_DEVICE=/dev/ttyACM1

make: *** [src/stm32/Makefile:111: flash] Error 255

any help would be appreciated!

Please continue here. There is no indication that your issue is bootloader related (unless you already killed it with your previous attempts).

So far, you simply did not configure your printer correctly. Once this is resolved, further diagnosis can be performed.