START_PRINT g-code making bed mesh twice

Basic Information:

Printer Model: Tronxy X5SA 2E
MCU / Printerboard: Stockboard
klippy.log (2.6 MB)

Describe your issue:

The problem is that when I start printing, the printer does the bed mesh twice: homing->bed mesh->purge->bed mesh->purge->print. I don’t mind if the bed mesh is done at the beginning of every print, but twice at the beginning is already a bit too much… In slicer machine code is STAR_PRINT and END_PRINT.

Hello @Brutalier !

In your start macro in Klipper, there is only one BED_MESH_CALIBRATE

[gcode_macro START_PRINT]
gcode = 
	{% set bed_temp = params.BED_TEMP|default(60)|int %}
	{% set extruder_temp = params.EXTRUDER_TEMP|default(210)|int %}
	{% set chamber_temp = params.CHAMBER_TEMP|default(0)|int %}
	M190 S{bed_temp}
	M104 S160
	G1 Z10.0 F3000
	G92 E0
	M104 S{extruder_temp}
	G1 Z2.0 F500
	G1 X0.1 Y20 Z2.0 F1500
	BED_MESH_CALIBRATE          # <------------
	M109 S{extruder_temp}
	G1 X10 Y20 Z0.3 F1500
	G1 X10 Y150.0 Z0.3 F1500 E15
	G1 X10.4 Y150.0 Z0.3 F1500
	G1 X10.4 Y20 Z0.3 F1500 E30
	G92 E0
	G1 Z5.0 F500

Check your slicer’s Start Print script if there is one too. Or START_PRINT is called twice.

There’s my machine code from slicer.

Do you have one setup in the frontend (OctoPrint/Mainsail/Fluidd) you use?

I’m using Fluidd and I’m still such a noob with these… :roll_eyes:

Just in case I checked calibration cube’s g-code and there is START_PRINT twice on start. :thinking: Maybe there is the problem? And what does that?

You use OrcaSlicer?

Try without the START_PRINT in the slicer scripts.

It appears that the slicer put one on it’s own.

Do you have start_print in your filament gcode settings?


There was the problem! Apparently I accidentally put the START_PRINT code in the filament section. Big Thank you for your help! :smiley: :+1:

1 Like

Im so happy that I stumbled across this post… Ive been dealing with a double purge line since I got klipper started!!!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.