Timeout homing on long Z

Ok, it’s not a significant problem, but it ought to be an easy fix.
If I home the machine from a high Z position, it times out before reaching the endstop.

Communication timeout while idle, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.

The cause is obvious: it just takes too long.
It isn’t a real problem: I can just hit ‘Home’ again, but it would be better to sort it…

And looking again, I think this is an Octoprint issue rather than Klipper, but hey ho…

As you correctly diagnosed yourself, this is an OctoPrint issue.
During the long running homing, Octoprint does not receive any updates. You can increase the timeout for such long running commands in the OcoPrint settings.

Yup. Found it now. Thank you.