Start print homing after tall print - is this a bug?

I have a problem that occurs on very tall prints. I’m not sure if it’s my setup or a general issue, but my coding skills are lame and I can’t work it out, so I’m hoping for some suggestions.

When a print finishes, the Z axis moves about 10 mm away from the part and to a set XY position and motors de-power and all is well.

On startup, the Z moves the bed about 10 mm away from the hotend, presumeably as a safety measure, then it homes XY and Z…

The above is fine if the height of the part is less than Z limit -20 mm but any more than that means the startup routine will crash into the Z limits (I don’t have limit switches on Z so it just crashes).

Does this happen generally or is it my setup that needs a coding tweak? My thought is that the start macro does not need to have any Z safety offset, since safety is built into the end and cancel macros.

Or maybe reduce the safety to a small amount, like 2 mm.

Where and how can I make changes to the startup offset (homing?).

Any other suggestions that will work as a general solution regardless of print height?

The best way to get an answer is to answer the questions and provide your klippy.log as came up when you first opened the form:

Basic Information:

Printer Model:
MCU / Printerboard:

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
Be sure to check our Knowledge Base and in particular this and this post

Describe your issue:

Thanks, sorry to have skipped those steps.

Printer is Rat-rig vcore 300
MCU is Octopus 1.1
Link to klippy log: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

If you don’t want to lift the tool head during your homing routine, then simply change your homing_override. This is entirely up to you to decide.

I personally wouldn’t eliminate it because in the event of an e-stop during the first layer of a print, you could do a lot of damage to the bed on a subsequent home if the nozzle drags. I limit my Z height to 10mm below the physical limit, and lift Z 5mm during homing so I never crash the top of the printer.

You use a lot of macros. I would go with this Failed to Load Crowsnest Extension - #4 by Sineos

Good luck, hcet14

That’s largely what I’m trying to do, but I can’t find out how to do it. I can add an override in the config file, but what parameter controls the amount of tool head lift? How would I set the value, like yours, to 5mm. Is there any documentation on the topic?