Touch calibration generic 10.1” touchscreen KlipperScreen

Basic Information:

Printer Model: Mercury One.1
MCU / Printerboard: Manta M8P 1.1/CB1

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

I am trying to get a generic 10.1” touchscreen working correctly with KlipperScreen. The display works, via HDMI, but the inputs are off. [Here](HMTECH Raspberry Pi Screen 10.1… is the screen I have. Here is a video of the issue. I have tried xinput_calibrator but couldn’t get it to work. I went through the touch troubleshooting section on the KlipperScreen site with no luck. I’m hoping someone here can shed some light on a fix.

I wanted to update this hoping someone had dealt with this. In order to eliminate the panel being faulty or damaged plugged it in via HDMI to my Windows laptop. It worked perfect. So I know now that the panel operates as it should. This is where things get weird:

-if I plug the HDMI into the CB1 but plug the USB into the laptop, touch registers on the laptop-perfectly registers position

-if I then plug the USB back into the CB1-not removing HDMI at all-the panel works perfect in KlipperScreen until I restart Mainsail or KS, anything on the printer, then is starts the wrong input again

-if I plug the USB into a regular charging block, not touch registers at all

-if I plug the USB into any power source other than the CB1 and run “DISPLAY=:0 xinput” it will not output the screen.

If I unplug the USB from the CB1 and wait for Mainsail to initialize then plug in the USB, KlipperScreen works every time.


I’m just guessing here, but if Mainsail is initialized then KlipperScreen also is initialized. Have you compared the fresh KlipperScreen.log First Steps/Log - KlipperScreen for each scenario?
The touch communication is done over USB. It might be an initialization problem.
Can you post the manual of your display?
You also could ask here on Discord Contact - KlipperScreen?

Good luck, hcet14

Hey Thanks for the reply. I went through the log with no errors or anomalies noted. It seemed as everything was initializing correctly too. One thing I missed during setup was adding to the trusted clients. I doubt that would make a difference, but I added it anyways. I did post on the Discord with no responses.

I don’t know this display.

… doesn’t provide much information.

There is zero info after searching for the model listed in Amazon, the number displayed through ssh and the number on the back. The QR code provided with the item linked to two different displays completely.

… but the A-giant says

Didn’t you get any paper with the display?

Its a small card with the word manual on it and 2 QR codes. Neither code links to relevant info.

Of course “Date First Available June 29, 2021” those are dead.

Can you describe all the interfaces, photos?

It’s HDMI and micro USB for the display and micro HDMI and USB-A for the CB1

Ok, you just connect HDMI and USB to your CB1?

Usually those displays use an extra USB port to power up LCD wiki have a look at the 10.1inch HDMI Displays.

Just a guess! Might be a power sequencing problem of the CB1 and your display. You might open an issue here Issues · KlipperScreen/KlipperScreen · GitHub

Sorry for not being a big help.

That’s all it’s really basic. I hadn’t thought of opening an issue on the GitHub. I’ll do that as well. Thanks for trying though.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.