Unable to install numpy no such file or directory

Fresh install of klipper using OctoPi-Klipper image sourced by Raspberry PI imager
Linux octopi 5.10.63-v7+ #1496 SMP Wed Dec 1 15:58:11 GMT 2021 armv7l
OctoPrint version : 1.7.3
OctoPi version : 0.18.0

If I run ~/klippy-env/bin/pip install -v numpy I receive the error No such file or directory.
What I am missing?

Maybe something went wrong during your initial install.
I’d try deleting your Klipper folders:

rm -r /home/pi/klippy-env
rm -r /home/pi/klipper

And then start from here: Installation - Klipper documentation

Closely watch the output of the installation steps if there is any error. If yes attach here.

1 Like

Did you execute:
~/klippy-env/bin/activate
Before the numpy install?

Should not be needed. If so, likely something else has gone wrong before why I still would recommend to redo the install according to the documentation.

Just today on discord I have seen that the OctoKlipper image is using a bad place for the klippy-env. It is not /home/pi/klippy-env, but /home/pi/klipper/klippy-env. It is inside the Klipper source directory, shocking!

To be honest, I fail to see how this is possible:

  • OctoPi as mentioned in the official documentation does not contain a Klipper install
  • The install script explicitly sets PYTHONDIR="${HOME}/klippy-env"
  • OctoKlipper is just an OctoPrint plugin that does not care about the venv

Of course possible if some is willingly mangling the install or doing other strange things. If someone is following the documentation surely this does not happen.

I believe they’re referring to this distro that includes Octoprint and Klipper preinstalled. It appears they just fixed this issue. Not sure why anyone thought that was a good idea in the first place.

1 Like

Okay, I know what the OctoKlipper-Plugin is and does. I just used a wrong naming. That doesn’t mean that I am wrong. For me there is a difference between an image and a plugin.

First, I just pointed out that it basically cannot happen when following the official documentation.
Second, I’d call many things in this world “shocking” but not a bug in a Linux image. Especially not when talking about the maintainer of OctoPi who is dedicating his free time to providing this since over 9 years.

I only tried to help with this issue, because I stumbled about it in klipper discord when I helped another guy.
What shocks me is my own business and of course YMMV.
But don’t worry, I will not try to help again

@Sineos Replying from my other post in regards to this same issue after installing Klipper via the Pi Imager OctoKlipper image.

When I remove the klipper folders and run a fresh install, would I need to run the [make menuconfig] to create a new bin file to flash to the printer mainboard?

If you already successfully flashed your board and your printer was connecting then there is no need to do it again.
One exception: If Klipper’s code base changed too much between two updates then you will receive an error message about a mismatch between host and board. Something along the lines:

mcu 'mcu': Unable ... REASON WHY KLIPPER IS UNHAPPY

This type of error is frequently caused by running an older
version of the firmware on the micro-controller (fix by
recompiling and flashing the firmware).

Known versions: host=v0.10.0-111-gdccd5554, mcu=v0.9.1-779-g59bd51d2, rpi=v0.9.1-786-gc2d3a168
1 Like

@Sineos, I followed the instructions above. I deleted the klipper folder, then did a fresh install of Klipper and reflashed the firmware as per the installation page. Now I get an error in Octoprint that tmp/klippy.log and tmp/printer does not exist, and klipper will not connect to mainboard in Octoprint.

Should there be a /tmp/printer folder? I dont see that either.

Any ideas what the issue might be?

Please post your klippy.log file. Also post the content of /etc/init.d/klipper

@Sineos

There is no klippy.log in the tmp directory. See image below.

Here is the klipper file from /etc/init.d/klipper

klipper.zip (819 Bytes)

I am thinking the Pi Imager must have corrupted the OctoKlipper install. Maybe do a fresh install of OctoPi and OctoPrint?

@Sineos

I reran the installer after running the recommended Klipper uninstall script and now it shows the printer folder and the klippy.log in the tmp directory after install.

sudo ~/klipper/scripts/klipper-uninstall.sh
rm -rf ~/klippy-env ~/klipper

Seems I had to run the script to get it to work. Thanks for the speedy help!

1 Like

hello, I am also using the OctoPi-Klipper image provided by the Raspberry PI imager, and I had the same problem, what happens is that in this image to install numpy the path is different, use this command:
~/oprint/bin/pip install -v numpy

it worked for me, hope it helps.

1 Like

THIS da man, this was the solution.