Unable to obtain 'adxl345_status'

Basic Information:

MCU / Printerboard: RPi Zero W + SKR mini E3 v2
klippy.log klippy.log (155.4 KB)

Hello, today I received two GY-291 adxl345 sensors, I have added an arduino nano via usb to the raspberry pi zero w and added the mcu to klipper, the ACCELEROMETER_QUERY gives me back information, but when I do a TEST_RESONANCES AXIS=X klipper turns off. I do not know what can be happening.

I have tried with thick wires and several original arduino nanos as well as reflashing the arduino several times. No matter if the sensor is mounted on the machine or static, it always stops when I do the test.

Also I have tried to connect it directly to the rpi and the same thing happens here the log:
klippy_to_SPI.log (165.6 KB)

Hello @xchgre !

Have you activated SPI on the Pi via sudo raspi-config ?

Yes, the ACCELEROMETER_QUERY command gives me random data every time I send it.

accelerometer values (x, y, z): -740.205942, -9622.677246, -459.657299

accelerometer values (x, y, z): -740.205942, -9696.697840, -383.047749

after several hours of testing and testing cat 6 cables, the solution is simple, lower the Output data rate for ADXL345 from the standard 3200 to 1600.

This should be in the “Measuring Resonances” documentation when explaining the configuration, I’m sure it has given a headache to more than one.

1 Like