Anycybic I3 Mega/orangepi zero 3/ adxl345/ i2c

Basic Information:

Printer Model:
MCU / Printerboard:

Hi. Im driving crazy with this. Im absolutely new in linux and pi boards, but know about electronics. I’ve asked and searched as much as i could, but not able to make it run, so came here.

  1. I connected 4 wires correctly between both boards (+3.3/gnd/sda/scl).
  2. I followed instructions from manual to activate i2c ports, and installed all manual says.
  3. i2cdetect -y 3 answers fine: 0x53
  4. Now comes my crazynest. Into klipper, dont know wtf put on adxl345.cfg file. tried a lot of variants useless.
    nearest one is:
    accel_chip: adxl345
    probe_points: 100, 100, 20
    At least, that one lets mcu connect and klipper dont give an y error…
    But when asking accelerometer_query, i obtain Invalid adxl345 id (got 0 vs e5).
    Dont know what to do, all info I find is for raspbery, spi connection and is not useful for me…
    Need some expert here!
    Thanks ans sorry for my english
    klippy.log (1.4 MB)

See Measuring Resonances - Klipper documentation

The ADXLs are extremely sensitive about the cable. An Ethernet cable Cat 5e is recommended using the wiring as described in wiring

Frst…thanks for answering!
I am pretty sure wiring is not the problem. Distance is really short, wires are good quality ones, and they are solded in both boards to avoid false contacts.
I’m having issues with " RPi microcontroller - Klipper documentation (", that commands are written to use it on rasp, nor orange. I could do almost all, varying routes as needed, and obtain a (i think) correct mcu at route “/usr/local/bin/klipper_host_mcu”
So, I write it on axl345.cfg on [mcu pi] part as serial: /usr/…mcu
Klipper amswers with a “cant conect to printer…”
So I suppose i need to go with next step on guide:
If klippy.log reports a “Permission denied” error when attempting to connect to /tmp/klipper_host_mcu then you need to add your user to the tty group. The following command will add the “pi” user to the tty group:

sudo usermod -a -G tty pi

But that step is not working with orangepi neither.
Im driving myself crazy with this
Dont know were the problem should be

I read this statement all too often. I have warned you

If you are not using the Pi then you will have to fight this through yourself.

  • The steps needed to get SPI up and running depends on the distribution you are using → Refer to the OPi documentation
  • The success rate with this depends on how well the board manufacturer implemented this in his distribution
  • All commands involving a username of course needs to be tailored to your actual user, e.g.sudo usermod -a -G tty pisudo usermod -a -G tty <my_actual_username_here>
  • Etc

If you do not feel like digging this deep into it, I’d recommend to get a Raspberry Pi Pico and connect the ADXL there. A complete instruction is in the official documentation.

Did you get it to work? Im getting the same “Invalid adxl345 id (got 0 vs e5).” error on my orange pi zero 3.
I even used an CAT 6 cable, used the official wiki to get the correct orangepi-config and so on. Im considering to either get a Pi Pico or a new sensor, as already put far more time into it than I should

matanel83 had similar problems.

Good luck, hcet14

No. Noway…i let that on a storage and forget allí baout that…Lost too much time and didnt get It work…
Orangepizero3 IS different,uses different routes, and you have to know well how Linux, SSH and that boards work, because you cannot follow nay step by step guide.
I recommend you to buy nay adxl with an USB interface, It Will be the easiest way, i suppose.

This is no rocket science!
I had an ADXL345 working with my OrangePi Zero. The only problem was getting Numpy installed. Therefor the RAM of the OPi was too small and had to be outsourced to the SD card into a temporary RAM file. This worked though it took ages… :smiley:

Sure ir isnt…bu i was not capoable to make It work.
First time i read about Numpy…what the hell IS that?
I think my problem IS dont know anything about Linux or ssh…
Anyway, i have surrender about that and made printing tests…

And in my case, RAM IS not a problem, mine IS a 2gb

1 Like

Everything installed without a problem on my side.
What I did so far:
Activated ph-i2c2 and spi1-cs0-spidev under orangepi-config
Added i2c-dev and spi-dev in /etc/modules

My printer.cfg:

[mcu rpi]
serial: /tmp/klipper_host_mcu
cs_pin: rpi:None
spi_speed: 488000
accel_chip: adxl345
100, 100, 20 # an example

Under /boot/orangepiEnv.txt I added


Installed numpy:

sudo apt install python3-numpy python3-matplotlib libatlas-base-dev
~/klippy-env/bin/pip install -v numpy

Followed the mcu guide

Installed dependecies

sudo apt-get install python3-dev python3-pip python3-smbus i2c-tools libi2c-dev
sudo apt install python3-numpy python3-matplotlib libatlas-base-dev python3-spidev

And still getting a “Invalid adxl345 id (got 0 vs e5).” error

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.