Unable to open file with new printer setup

Basic Information:

Printer Model: anycubic kossel linear
MCU / Printerboard: BTT/BiQu SKR mini E3V3 TMR 2209 RPI 3A+ with Raspi cam

klippy (4).log (293.7 KB)

Error message:

Describe your issue:

gcode file will not print “unable to load file” any file any time. File works in the viewer. File shows up in the gcode list. Files exist on the raspberry pi. None will print.

System will home and heat, but won’t read gcode. It is all but printing at this point.

Have tried:

  1. changing from user home path shortcut (~/printer_data/gcodes) to absolute path (/home/pi/printer_data/gcodes) in printer.cfg and it fails both ways. Searching shows that is the common solution (change that path), but this has not worked. I went so far as to edit the config.cfg file in mainsail that the other simlinks point to and then when it came time to update, klipper said the file was dirty because of that change.

  2. changed permission of both the gcodes folder and the files to 777

  3. renamed the file to have all lower case letters

I am comfortable enough with linux to know how to write a path. The path exists.
Can another set of eyes see what I must have I overlooked that isn’t covered in all these other responses?

FYI, this will be my second klipper printer. The first one is printing right now while this one sits refusing to work. The other one just worked.

Thanks for any help or suggestions!

Maybe change the following section accordingly:

path: ~/gcode_files
on_error_gcode: CANCEL_PRINT

and test again.

1 Like


I see it now. I pasted in a section with the header info and it isn’t a comment… so on_error_gcode line in the klippy.log is like 20 lines below where it should be. It was a simple cut/paste error where an arduino comment in C++ was pulled in as part of the [virtual_sdcard] section rather than ignored like a comment. Made it into a comment with parts added in red and it works now:

the actual line:

path: ~/gcode_files



but the lines after it had to be commented out.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.