Voron 2.4 canbus not extruding during print, but perfectly during tests

Basic Information:

Printer Model: Self sourced Voron 2.4
MCU / Printerboard: Octopus / U2C / EBB36
klippy (5).log (5.1 MB)


Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed

Describe your issue:

Recently switched to canbus on my perfectly working Voron 2.4. With an U2C 2.1 and EBB36 1.2 . Worked fine at beginning.

The problem I have is simple, it extrudes perfectly when it prints the start line I had put in the start_print macro, or even when I extrude manually with Fluidd, or even on Klipperscreen. No problem at all when I do like that, but during real beginning of print, it doesn’t do anything more than oozing what remains in the nozzle.
I checked everything It’s not a mechanical issue, or wiring, and it would not extrude normally during tests if it was the case.

I tested with known good sliced stls, tried slicing other ones etc etc, tested so many things I can’t list them. And there was no change at all in the config between working config, and now. Only klipper and fluidd updates.

I also have random klipper shutdowns due to EBBCan loosing connection, but only during homing or QGL, but never during print.

Just in case it helps can is wired with an Igus Chainflex cable, so a good quality and twisted one.

If you can see anything in the klippy log, I would be so thankfull!!

Edit: also forgot to say, I tried canbus speeds from 250000 to 1000000. No change

And last one, the emergency shutdown is wanted, I done it just after another printing test, to make the problem more easy to “read” in the klippy log