Z axis travel adjust

Basic Information:

Printer Model: Bonsai
MCU / Printerboard:OVM2 Lite (RAMPS clone)
klippy(9).log (303.6 KB)

Hello! I’m trying to configure Klipper for this printer and I have this problem with the Z axis. I can’t adjust the travel. I ask for 10 mm of travel and it just moves 4 or 5 mm. This isn’t my first contact with Klipper but I am new in this maner. Can you help me? Thanks! :pray:

1 Like

Hello @simon !

Have you tried it with a rotation_distance of 4 for the Z-axes?

What kind of Z-axes lead screw do you have?

Hi EddyMI3D!
Yes I did. Tried changing microsteps too and just moves slower/faster with a bit more or less travel.

You also may check that the jumpers below the stepper module are set to the desired micro stepping.

Maybe also the current of the stepper motor can be too low.

Is it this printer you are working on?

The board doesn’t have jumpers for the micro stepping and I have used this board in other projects without any issues.
Tried changing the current to the steppers and still no change, and yes that is the printer. I was willing to built a Voron 0.2 but it is a bit expensive so I choose this one.

Side note on the board:
Due to the limitation on 12V and the used drivers the overall performance of the board is quite limited. Not sure if it is worth investing into it.

I did lower rotation_distance to 2. Gives this error:

MCU ‘mcu’ shutdown: Rescheduled timer in the past
This generally occurs when the micro-controller has been
requested to step at a rate higher than it is capable of

What do you mean with the side note?

Lower your microstepping to 16 and if new issues arise please always post the klippy.log as well.

This error almost answers your second question:

This board has several shortcomings and I’d personally would not use it in any printer today:

  • 12V VCC will severely reduce the steppers dynamics and acceleration capabilities (same is true for the heating elements like extruder and bed)
  • The used drivers are very simplistic and far from the fine-grained control modern drivers are offering
  • The used MCU is very weak and you can easily get errors like yours above. This error is quite rare these days, since such weak boards have almost vanished.

This is a Anet A8 era board and back then it might have been a nice option.

Lowering the microstepping worked but still didn’t travel what I asked. I leave here the klippy.log if you want to take a look at it. And could you give me some guidelines on how to interpret this log.
klippy.log (166.8 KB)

I was afraid you were going to say that! And a very good explanation of why I should by another board, you really know what you are talking about! In your opinion what is a good board to by? Thank you! :pray:

Thread rotation_distance
M8 2
M8 1.25
5/16 1.41111

The table above shows the most common lead-screws. I suggest the following procedure:

  1. Measure the distance between your X gantry and the top of your bed
  2. Command the bed to move 20 mm
  3. Measure again and do <second measurement> - <first measurement>
  4. Calculate
    rotation_distance = <current_rot_dis> * <result No. 3> / <20>
  5. Compare to the table above and see if you come close

In general your klippy.log does not show anything unusual.

There are so many good boards and depending on your needs and how much money you want to spend:

to name a few.

With 16 microstepps and rotation_distance of 2 the result is 0.09.
What do you think about the SKR mini E3?

This somehow makes no sense as 0.09 can never be a valid lead-screw. Are you sure you got it correct, i.e. measuring and calculating?

I cannot really comment on this one. Just my gut feeling is that there are quite a few issues reported around this board, but it may well be due to its popularity. From its general setup its a nice board.

You are right! My mistake, the result is 0.9 still I agree with you it doesn’t make any sense! I will measure again.

I measured it again and it gave me 1. The near value is 1.25 which gives the rescheduled timer error. I lowered it until 1.48 and is almost there but not yet. What do you think?

You are getting a Rescheduled timer in the past here? Please post a new klippy.log

In general, please always provide a klippy.log when you changed something and issues pop up.

I’m sorry about the delay!
Here is the log.
klippy.log (19.2 KB)

Your log does not contain any error. What is the current status?

Microstepps 16 and rotation_distance 2. When I ask to move 20mm it moves +/- 9mm.

Then the rotation distance is wrong.

  • As previously indicated microstepping does not play a role when setting rotation_distance
  • The value above would indicate that a rotation_distance of ~1 is needed and I do not know any lead-screw that would have this
  1. Do you have a link / description / data-sheet for the lead-screw?
  2. Verify the current of your z-stepper and set it approximately to 80% of the max current of your stepper motor
  3. Closely inspect your z-motion system
    • Does it run freely, i.e. no binding, hard-going, etc
    • Does the lead-screw run smoothly in its nut?
  4. Modify
    max_z_velocity = 5
    max_z_accel = 100
    max_z_velocity = 2
    max_z_accel = 50
    and repeat the measuring procedure I have provided above