3D Touch - Always triggered and more

Basic Information:

Printer Model: Ender 3 Pro
MCU / Printerboard: Stock 4.2.2
klippy.log

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed

Describe your issue:

klippy.log (1.2 MB)

Had this 3D Touch for a few years on my Ender 3 Pro and it’s been working great (stock “marlin” from Creality). I decided I wanted the features of Klipper (to many to list), so I went and did the things to my printer and got ready to enjoy the process of setting it all back up.

First thing I did was start setting up the printer.cfg file, and loading up the 3D Touch odds and ends. I followed all the links I could find, and they all basically turned out the same (with minor differences listed below).

Links I used (not in order - and I guess I can only include 2 or 1?):

Chris’ Basement BL Touch - Auto Bed Leveling - he basically followed the Klipper documentation.

BL Touch - Klipper Documentation (Won’t let me use the link, but it’s the official Klipper doc).

Reddit - Klipper + Ender 3 v4.2.2 board + 3D Touch clone
and
Reddit - BLTouch reports as triggered.

BLTouch with Klipper and the Ender3 - This was an early follow along tutorial by Tomohulk on gitbub. He’s using a little different hardware, but I adjusted to my own.

Tore open my printer to get my board info and it was indeed a 4.2.2 with the STM32F103 chip (when making Klipper it said that was important to know). My 3D Touch was plugged in “typical” with the 5 pins and z access unplugged.

Initially it did all the same readings as below, but would NOT do home (G28 - it would do X/Y, then go the center of the bed, and tell me it couldn’t tell where the pin was, or that it couldn’t verify if the pin was stowed. After that struggle, I moved the black and white pins to the z stop slot on the MCU, and now it’ll home but won’t mesh, and continually shows triggered in the command, but on the UI for Mainsail it shows open).

The issue(s) is(are): (With z stop on board used by 3D Touch)
QUERY_PROBE
probe: TRIGGERED

BLTOUCH_DEBUG COMMAND=touch_mode
BLTOUCH_DEBUG COMMAND=pin_down
(pin clicks down)

QUERY_PROBE
probe: TRIGGERED

BLTOUCH_DEBUG COMMAND=pin_up
(pin clicks up and stays)
BLTOUCH_DEBUG COMMAND=pin_down
(pin clicks down)

QUERY_PROBE
probe: TRIGGERED

BLTOUCH_DEBUG COMMAND=reset

BLTOUCH_DEBUG COMMAND=pin_down
(pin clicks down)

G28
(moves to home x/y double tapps z and finishes)

If I try to G28 with pin_up, it does x/y then crashes into the bed (I pulled my PEI sheet off before I tested because I’ve ruined more than one nice bed item doing this :wink: ).

If I pin_down, home, pin_down, Heightmap it clicks up, down, up, die … sigh!

When I boot up the printer/Mainsail it gives me: “Failed to verify BLTouch probe is raised; retrying.” no matter if the pin is up or down. It does to it’s 3 click self test when I start it up, but doesn’t seem to remember where it left the pin.

I’m at a loss. I tried it using the “normal” 5 pin hookup on the MCU, then tried the z stop method (not my fave because using the 5 pins in a row looks cleaner).

Any assistance is appreciated. I’ve found that most issues are either hooked up wrong, pin doesn’t move (mine works well and I re-checked the screw on top for adjustment), or they’ve got a wonky BLTouch clone (I’ve got several, and tried them all with the same results so I know it’s “probably” my cnf file editing prowess.

Thank you

AFAIK, the only difference between using the 5 pins in a row, or plugging into the Z endstop, will be the sensor_pin number specified in the [bltouch] config. It should work in either port, just make sure that the sensor_pin is the right one for that port. Note that the documentation says that this pin will most likely need to be pulled high, by using the “^” character before the pin number

Also, there are 2 settings in the [bltouch] config that seem to be related, they are “pin_up_reports_not_triggered:” and “pin_up_touch_mode_reports_triggered”, It would be worth reading up on these to see if they will address your problem

Finally, there is a section in the documentation dedicated to the bltouch (BLTouch Documentation) it is worth reading through it to understand what is going on.

Hope this helps

You’re correct, you’ve got to change the pinout in BLTOUCH depending on if you choose the 5 pin block or choose to use the z stop (did that :slight_smile: ). My printer isn’t on right now but I’ve got them both in my printer.cfg file (# out the line I don’t need depending on which pins I’m playing with).

Also correct, the carrot symbol tells it to use the pull-down resistor (good to go there too). Tried to play with that also. Found a tutorial where he had to use both the carrot and the ! symbols, but that wasn’t even close to my case, so I didn’t put much effort into it.

After I get done here, I’ll try the pin_up_touch_mode_reports_triggered and see if that helps I already did the pin_up_reports_not_triggered, and a few others I found online here and there.

I tried to add all the links I used, but it limited me to, two, and one of those was my klippy.log file. I have the Klipper documents site bookmarked (and tried to point a link to the BLTouch section, and the BLTouch Clone section but I hit my limit early :smiley:), and used the BLTouch section to bump against what I had. I also read over the “clone” portion but neither changed the outcome.

Thank you for your time jrobborn5, I’m a long time opensource enthusiast and it’s helpful people that keep the world moving.

1 Like

Hi, Were you able to resolve this issue? I recently shifted to klipper on base Ender board with 3D Touch and facing the same issue