All Motors not moving

Basic Information:

Printer Model: Heavily modifiyed Creality Ender 5 (CoreXY)
MCU / Printerboard: STM32F103 RET6, Creality Board 4.2.7
klippy.logklippy (3).log (1.2 MB)

Describe your issue:

Hi. I decided to switch from Marlin to Klipper. Now I have Mainsail and most functions are working. The big Problem is, that all the Motors aren’t moving. When the System is started I can move the motors freely. As soon as I start the homing process the motors are locked but not moving until the system failes the homing.
The motors worked without any problem with Marlin and the Enable pin works correctly as far as I understand. Inverting them doesn’t help.
I’m hoping someone can tell me what I’m doing wrong. Btw this is my first Forum post ever, so if your missing any information feel free to ask.

Hello @Stefan5454 !

Did you run the configuration check?

https://www.klipper3d.org/Config_checks.html

Thanks for the quick answer.
Yes I already looked into it. Everything works fine until " Verify stepper motors". STEPPER_BUZZ is not able to move the Motors.

The heaters work?

So the board get’s power.

Are motors connected properly to the board?
Do the stepper drivers have an issue?

Is there any noise coming from the motors when trying to home axes or performing STEPPER_BUZZ?
I assume it worked fine under Marlin or did you change hardware along with moving to Klipper?

The heaters do work yes. Board has power. Stepper worked fine before, all hardware modifications whe teseted with Marlin.

No hardware changes. I can only hear the activation of the Motors, but no noise while trying to move.

Did the motors run in UART mode with Marlin?

It seems your step_pin and dir_pin are swapped.

3 Likes

Thanks that worked. I copied them from another config.
You safed my day. Thanks everybody for the realy fast answers.