Arduino due configuration

Hello all,
I’m trying to set up an arduino due board but with no results.
Inside the OctoPi console the following message is displayed: “MCU ‘mcu’ shutdown: Not a valid ADC pin”.
Do I have to define all the pinout of the board?
Attached you can find both the “klippy.log” and the “printer.cfg”:
klippy.log (5.3 KB)
printer.cfg (4.9 KB)


None of the sensor pins you have defined for your extruders or bed are analog, so none of them can be used for ADC.


You may stock to this pinout:

1 Like

Thank you!

I have a modified Ultratronics so the pinout should be the same, right?

Then you should stick to your board’s documentarians pinout, because some MCU pins are not connected on that board.
You can use the Arduino pinout to get the correct pin number for Klipper.



So a thermistor goes to connector T0. That is pin A0/D54 of the MCU that is PA16 in Klipper

1 Like

I didn’t specify that and I’m sorry… I need to connect thermocouples and not thermistors but I can’t find any documentation about it.

I really appreciate the help you are giving to me

From some quick Googling on that board, it uses MAX31855 ICs for the thermocouple inputs. I’ve linked the relevant Klipper info below, and I’ll provide an example for one of your extruders. I would suggest configuring one sensor and extruder at a time to confirm each one is working. I’ve only provided the minimum config info, and you may need to specify more details or change the thermocouple type (default is K type). I pulled the sensor pin from the Ultratronics Pro data sheet which lists the thermocouple CS pins as:

TC0 = D65 = PB20
TC1 = D52 = PC13
TC2 = D51 = PC12
TC3 = D50 = PB21

step_pin: PA22
dir_pin: PA6
enable_pin: !PA20
microsteps: 16
rotation_distance: 33.500
nozzle_diameter: 0.400
filament_diameter: 2.850
heater_pin: PC21
sensor_type: MAX31855
sensor_pin: PB20
control: pid
pid_Kp: 22.2
pid_Ki: 1.08
pid_Kd: 114
min_temp: 0
max_temp: 450
1 Like

I don’t know why but the console displayed this:

Send: status
Recv: // Option ‘tc_type’ is not valid in section ‘extruder’
Recv: //
Recv: // Once the underlying issue is corrected, use the “RESTART”
Recv: // command to reload the config and restart the host software.
Recv: // Printer is halted
Recv: // Klipper state: Not ready
Recv: !! Option ‘tc_type’ is not valid in section ‘extruder’

It appears that’s only a valid option for the MAX31856, so delete the tc_type line.

Good news, now the terminal display Bed and T0 but without the current temperature.

Recv: ok B:0.0 /0.0 T0:0.0 /0.0

this is what “status” command tell me:

Recv: // MAX31855 : Open Circuit
Recv: // Once the underlying issue is corrected, use the
Recv: // "FIRMWARE_RESTART" command to reset the firmware, reload the
Recv: // config, and restart the host software.
Recv: // Printer is shutdown
Recv: // Klipper state: Not ready
Recv: !! MAX31855 : Open Circuit
Recv: ok

You’re on your own from here. I gave you info I was able to find online for that board. Either you have a hardware issue, or the data sheet I found was incorrect. Either way I can’t offer any more help.

No problem!
Thank you so much for the help.