MCU 'mcu' shutdown: ADC out of range



Ender 3v2

Firmware version: v0.10.0-278-g7c964e5f
klippy.log (1.7 MB)

it stopps during print and said mcu failure etc after restart it shows bed temp over 700C
if i switch the termistor with the one from hotend under octoprint the value does not change
pretty wired cause if the thermistor is broken it should change the value

Has anyone a clue for me ? has also tried a brand new thermistor same problem just got over 700C shown
printer.cfg (5.3 KB)

This sounds like a broken cable for the temperature sensor. Can you check if it is ok?

I have test with other thermistor and also i have a view new ones from hotend- sadly same problem

Typically this error is caused by a hardware defect:

  • Thermistor itself
  • Cable
  • Connector
  • Port on the board

Connect the problematic thermistor to another temperature port on your board. If it then works, then the port on your board has died.

Hi, as I said if I switch the thermistor from hotendport to bed and vice versa- the bed temperature under octoprint stays on bed temp ~700c so i don’t think it’s the thermistor itself :confused:

Could I check anything in port itself ? Or you think it’s a board defect than will i order a new one

Well, if:

  • you already tried restarting the klipper service / rebooting your RPi / cutting power to your entire setup
  • it worked before
  • it suddenly stopped working
  • you have not modified your config (PC3 seems the right pin)
  • you have verified cable and thermistor with the other port

then the chances are high that your board died.
At least, I do not know any more reasons.

Yep all tried - than the board ist crap - I will order the V3 - thanks for your support

Another thing to try might be to connect the thermistor to a different port on the board and change the config to the other port. This of course requires to have another port available. That way you can exclude that you miss something elsewhere…

Was there any work done to improve logging details of these messages?

Currently it is still a pain to determine which thermistor is failing, I was looking at the logs and still can’t determine which one is causing the problem.


See Advanced Trouble-Shooting / Graphing Klipper
This might help in diagnosing