Bored with board with CAN connection

Basic Information:

Printer Model: Vcore3
MCU / Printerboard: Ooctopus pro + U2C + EBB42
klippy.log (3.7 MB)


Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed

Describe your issue:

Let’s see another day plagued with failures, it’s the same request as always, but although I was very interested in installing a Canboard connected by CAN, everything has been failures, the closest I’ve been is a Mellow SHT42, but with which I could NOT print not a single layer…

I have been following another guide, which are the components I want to install:

Following the steps of the video well, but when I get to minute 12 approx, I have already flashed, wired and configured everything… and restarted… I send the script to find out the UUID, but I get the same error as other times .

The truth is that I am getting tired of NOT being able to use the printer, I had high hopes for the connection with the toolboard by CAN, but I am losing them.

When I get to minute 12 or so, and send:

~/klippy-env/bin/python ~/klipper/scripts/ can0,

this bug

pi@ratos:~ $ ~/klippy-env/bin/python ~/klipper/scripts/ can0
Traceback (most recent call last):
File “/home/pi/klipper/scripts/”, line 64, in
File “/home/pi/klipper/scripts/”, line 61, in main
File “/home/pi/klipper/scripts/”, line 21, in query_unassigned
File “/home/pi/klippy-env/local/lib/python2.7/site-packages/can/”, line 127, in new
return cls(channel, *args, **kwargs)
File “/home/pi/klippy-env/local/lib/python2.7/site-packages/can/interfaces/socketcan/”, line 594, in init
bind_socket(self.socket, channel)
File “/home/pi/klippy-env/local/lib/python2.7/site-packages/can/interfaces/socketcan/”, line 462, in bind_socket
addr = get_addr(sock, channel)
File “/home/pi/klippy-env/local/lib/python2.7/site-packages/can/interfaces/socketcan/”, line 62, in get_addr
res = fcntl.ioctl(sock, SIOCGIFINDEX, data)
IOError: [Errno 19] No such device

I could solve this error previously, with a script that you passed me through the forum, this one:

sudo ip link set up can0 type can bitrate 500000

But having the Can Board configured like this, shortly after starting to print, the printing fails, a time out error, and if you looked at the Ifconfig, you could see many packages with errors…

This couple of days I have tried the combination: Octopus Pro + U2C + EBB42… the three elements of Bigtreetch. As a note to review is that I have flashed the Candelight firmware in the U2C.

and I followed another video guide, this time:

Another point is that if I command “ifconfig”, the CAN0 network interface does not appear.

For it to appear, I have to send a script…

A few days ago, I was very happy because I got it to be, another combination:

Octopus Pro - Utoc 1 - SHT 42

But the joy didn’t last long, since shortly after, in the first printing job, it stopped due to timeouts…

That’s partly why I decided to change to the EBB42… but nothing.

Does anyone have an idea what I may be doing wrong?
This time there is something new… before, although the script failed, it sent this to the console:

sudo ip link set up can0 type can bitrate 500000

and at least the network interface CAN0 appeared with ifconfig, this time, if I send it the script, the response is:

Cannot find device “can0”

So I don’t know very well what I can do, I have also seen that there is a firmware update, which I think modifies something about the CANBUS.


The Can0 Network… Does it have to be visible only with the Can adapter connected by usb to the RPi? Do you need the can board, Ebb42 or Sht42, to be connected? I ask is to try things in parts. Connect only the canbus adapter (U2C or Utoc1) and see if they activate the can0 Network

Sorry, but the thread title is quite confusing.
Do you mean Board with CAN bus connection?

Ok… My English could be better

Do you have the 120r jumpers installed on the EBB and the U2C?

No… Only in Ebb where they go? Think I have see in manual… Tomorrow try