Cannot connect to the mcu

Basic Information:

Printer Model: ender 3v2 neo
MCU / Printerboard: stock board v4.2.2 i think
Host / SBC rasberry pi zero2w
[log](https://klippy (2).log)

klippy (2).log (448.7 KB)

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

… fluidd will not connect to the mcu i have tried everything i could understand from the knowledge base any help i am very thankful for.

You’re using the generic example for the mcu connection, you need to figure out what yours is specifically.

Do you have SSH enabled on your Pi? If so, do you know how to connect?
You need to run…

ls /dev/serial/by-id/*

on the command line to see what your printer mcu is.

Should look something like this…


i did this and my mcu was the same as the generic.

Any chance you can post a screenshot of what the ls /dev/serial command output looks like for your board?


This might sound weird but try it for me, Try taking out the

restart_method = command

and then trying connecting again

i deleted it and it still cannot connect, aslo thank you so much for your help.

i have installed the sprite se extruder from creality. it is plug and play so i don’t think it would change anything but maybe it will?

update somone suggested i run by-path and i got this id

Sorry I got pulled away for work, Did you try using that and see what happens? By-Path is common for certain types of boards.

Methodically work through: Issues flashing the printer board

i tyed conecting again but do i have to reflash?

i have worked through all of it and it still will not connect

Did you reflash with triple checking that you used the correct settings and following the guidelines for flashing WRT SD card and file naming?

Follow How-To Trouble-Shoot and attach the dmesg.txt file

yes all make menu setting are correct. its fat 32 and its a .bin with a changed name
txt file would not generate so i had to take pics of the text, sorry.

will starting from scratch fix it

This is almost impossible, but so be it.

I’m not going to analyze a dmesg via screenshots, but a casual look seems to indicate some weird messages for an official RPi distribution has not been tinkered with.

No further idea.

i just discoverd i have a cloned board gd maybe this will change it

the problem was a broken sd card reader