Mcu 'mcu': Unable to connect continuesly

Basic Information:

Printer Model: Ender 3 S1 plus
MCU / Printerboard: CR-FDM-v24S1_301 or
klippy(6).log (963.5 KB)

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

I tried all the possible solutions
reboot pi4B and printer
jakez@Ender3S1:~ $ ls /dev/serial/by-id
raspberry pi lmager 64 bit


Make sure you are building for the correct MCU type. Closely read and check the header information here:

my printer is plus version

printer cfg

This file contains pin mappings for the stock 2022 Creality Ender 3

S1 Plus. To use this config check the STM32 Chip on the Mainboard,

during “make menuconfig” select accordingly either the

STM32F103 with “28KiB bootloader” or the STM32F401 with

“64KiB bootloader” and serial (on USART1 PA10/PA9) for both.

For a direct serial connection, in “make menuconfig” select

“Enable extra low-level configuration options” and Serial

(on USART2 PA3/PA2), which is on the 10 pin IDC cable used

for the LCD module as follows: 3: Tx, 4: Rx, 9: GND, 10: VCC

Flash this firmware by copying “out/klipper.bin” to a SD card and

turning on the printer with the card inserted. The filename

must be changed to “firmware.bin”

With STM32F401, you might need to put “firmware.bin” in a

folder on the SD card called “STM32F4_UPDATE” in order to flash.

See docs/ for a description of parameters.

step_pin: PC2
dir_pin: PB9
enable_pin: !PC3
microsteps: 16
rotation_distance: 40
endstop_pin: !PA5
position_endstop: -10
position_max: 316
position_min: -15
homing_speed: 50

step_pin: PB8
dir_pin: PB7
enable_pin: !PC3
microsteps: 16
rotation_distance: 40
endstop_pin: !PA6
position_endstop: -10
position_max: 304
position_min: -15
homing_speed: 50

step_pin: PB6
dir_pin: !PB5
enable_pin: !PC3
microsteps: 16
rotation_distance: 8
endstop_pin: probe:z_virtual_endstop
position_max: 300
position_min: -4

step_pin: PB4
dir_pin: PB3
enable_pin: !PC3
microsteps: 16
gear_ratio: 42:12
rotation_distance: 26.359
nozzle_diameter: 0.400
filament_diameter: 1.750
heater_pin: PA1
sensor_type: EPCOS 100K B57560G104F
sensor_pin: PC5
control: pid
pid_Kp: 23.561
pid_Ki: 1.208
pid_Kd: 114.859
min_temp: 0
max_temp: 260

heater_pin: PA7
sensor_type: EPCOS 100K B57560G104F
sensor_pin: PC4
control: pid
pid_Kp: 71.867
pid_Ki: 1.536
pid_Kd: 840.843
min_temp: 0
max_temp: 100

[heater_fan hotend_fan]
pin: PC0

pin: PA0

serial: /dev/serial/by-id/usb-1a86_USB_Serial-if00-port0
restart_method: command

kinematics: cartesian
max_velocity: 300
max_accel: 2000
max_z_velocity: 5
max_z_accel: 100

sensor_pin: ^PC14
control_pin: PC13
x_offset: -31.8
y_offset: -40.5
z_offset: 0
probe_with_touch_mode: true
stow_on_each_sample: false

speed: 120
mesh_min: 20, 20
mesh_max: 283, 263
probe_count: 4,4
algorithm: bicubic

home_xy_position: 187, 192
speed: 75
z_hop: 10
z_hop_speed: 5

[filament_switch_sensor e0_sensor]
switch_pin: !PC15
pause_on_runout: true
runout_gcode: PAUSE

recover_velocity: 25

Then check against
You need to identify your MCU type and follow the given instructions.

Thankyou the problem is solved!
I am not sure how to close this

1 Like