Cant connect to SKR 2 board

I have installed FLUIDDPI i on my Rasberry PI 4b.
My problem is that I am not able to connect to my SKR 2 board.
When i try to use the command ls /dev/serial/by-id i get the result as follow:
pi@fluiddpi:~ $ ls /dev/serial/by-id/*
ls: cannot access ‘/dev/serial/by-id/*’: No such file or directory
pi@fluiddpi:~ $
I have tried four different usb cables in all usb ports on the PI.
When i use Octoprint and Marlin the usb connection works with all of the four usb cables.
I have made a file for flashing with menuconfig and have set the values as shown in picture

I took the file klipper.bin and copied it to a sd card renamned it to FIRMVARE.bin.
I then tock the sd card and inserted the sd card into the SKR 2 bord. I did a reset on the SKR2 board twice and checked so it whas renamed to FIRMWARE.cur.

I dont know what to do next and wonder if someone can help me with this issue.

[klippy.log|attachment](upload://rXRrzgVSOGoMVdQ28EfTYK2BpUa.log) (165.3 KB)
[fluidd-access.log|attachment](upload://ijTyqsdPScmX31aZl2GEBLyfXn5.log) (45.3 KB)
[fluidd-error.log|attachment](upload://6NCasNrnD0t8ZMjuIhG8dB7lMLq.log) (681 Bytes)
[printer.cfg|attachment](upload://cycKrljuvRLHLSK4roCuqzm02NE.cfg) (5.8 KB)

Run the command dmesg and paste the output here.
The SKR2 board seems troublesome with the RPi4. See Klipper@skr mini 2.0 +rpi4 - #2 by hideous

Thanks for the advice.
I have attached a textfile with the result of the dmesg command.result dmesg 1.log (138.3 KB)
I power the pi4 with a power supply MEAN WELL RS-15-5 ( 15W 5V 3A) and a usb c cable (exactly the same as in picture)

I have set the output voltage from the power module to 5.1v.

I have tested with two Raspberry pi 4 with same result.
I have tested to attach other usb devices to pi 4 and they worked fine,
I have updated the Pi 4 firmware and have done another dmesresult dmesg 2.log (32.3 KB)
g output.

If you check your dmesg logs you will see a lot of USB errors, e.g.

[   21.864632] usb 1-1-port4: unable to enumerate USB device
[   23.464264] usb usb2-port2: Cannot enable. Maybe the USB cable is bad?
[   28.014334] usb usb2-port2: Cannot enable. Maybe the USB cable is bad?
[   32.354390] usb usb2-port2: Cannot enable. Maybe the USB cable is bad?
[   32.354818] usb usb2-port2: attempt power cycle

So apparently the RPi and the board are not exactly best friends. If you google for these errors you will find a ton in relation to the RPi4 models. So at the current stage there is nothing Klipper could do, as the communication between your board and the RPi already fails on hardware or kernel level.

You could try the advice from here: Put tape on the 5V pin - Why and how - FAQ - OctoPrint Community Forum

One last resort maybe is to install the official Raspberry Pi OS distribution and try there

If the above does not work run (following commands ideally should only be run in the official Raspberry Pi OS distribution and not any other distributions):

sudo apt install rpi-eeprom
sudo rpi-eeprom-update
sudo reboot

If the above does not work run:

sudo apt-get install rpi-update
sudo rpi-update
sudo reboot

If the above does not work run:

sudo BRANCH=next rpi-update
sudo reboot

Note that the rpi-update commands do come with a risk and may end up with a RPi that needs extensive unbricking.

Finally it may be a hardware issue with your board or the RPis.
Unfortunately, I cannot offer any more advice.

Thanks so much for your helpSineos.
Unfortunately, it did not work and it is probably a hardware problem. I have to go back to Marlin which for some reason works.