Can't get MCU ID from Ender 3

Basic Information:

Printer Model: Ender 3
MCU / Printerboard: Not Sure?
klippy.log Not sure what this means.

Describe your issue:

I am a Klipper noob, I have never used it before.

I am trying to use a laptop to run Klipper (boo raspberry pi shortage). It is running the latest version of Linux Mint Xfce.

I have successfully downloaded the KIAUH and can navigate to the Mainsail interface through my web browser.

I am stuck on identifying the MCU connection that I have with my Ender 3. I have plugged the USB from the Ender 3 to my laptop and have tried running the run ls /dev/serial/by-id/ but keep getting errors. I have tried issuing this command both from the laptop itself, and also on a separate desktop using PuTTy to get into the laptop.

I believe this to be the last thing in my way to actually using Klipper for the first time. I’ve read guides and watched videos, I understand how I will have to update the config file and everything going forward, but as Mainsail cannot detect my printer until I inform it of the usb/serial id I cannot go further (if I am understanding this correctly).

Anything helps, again I am an absolute noob and may be missing something obvious. Thanks!

There are different Ender 3 versions and these need different approaches how to flash and different configs. Open the printer and identify its board.

1 Like