Error after homing Y

I am running into an issue with my new installation. Using a RPi4, and BTT octopus, I get an MCU Shutdown Time too close. I know this is generally a hardware issue but I am pretty sure it’s not in this case. Only homing Y causes the issue. It actually moves to the endstop, triggers and then throws the error. If I manually trigger the endstop, not homing, it’s fine.

I have tested, with 2 different RPi’s, a 4B and 3B. All the below was run on both Pi’s and all 3 sd cards.
I have tested 3 sd cards, 1 brand new. All class 10.
I have tested with official RPi power supply, powering from the BTT Octopus and PC USB.
I have swapped the X and Y drivers, still gets an error
Moved the Y driver to another socket, still does it
Tried 3 different endstop ports, still doing it.
Tried Mainsail and Fluidd

Any ideas?
klippy.log (129.5 KB)

Hello @AgentNoise !

Are you using endstop switches or sensorless homing? You setup both.

You may have a deep look on this:

I am using endstop switches.

Even if I completely comment out the TMC2209 config, like the attached config it still does it. If you looks at the last config dump in the klippy.log it shows no TMC configuration.
Printer.cfg (3.8 KB)

When after homing Y, the error occurs, the printer is the Z homing cycle.

You have a coreXY printer setup with 3 driver z-axes.

step_pin = PC13
dir_pin = PF0
enable_pin = !PF1
microsteps = 16
rotation_distance = 40
endstop_pin = PG13
position_endstop = 0
position_max = 200
homing_speed = 50

step_pin = PE2
dir_pin = PE3
enable_pin = !PD4
microsteps = 16
rotation_distance = 40

step_pin = PE6
dir_pin = PA14
enable_pin = !PE0
microsteps = 16
rotation_distance = 40

If you use some kind of spindle for the z-axes, the rotation distance seem to be quite high.
Also the z-axis homing_speed.

I commented out the other 2 z steppers, reduced the speed and the rotation distance. Same result.

I’m not sure why it would be running the z home sequence anyway. I only sending G28 Y should just do the 1 axis.
Klippy_2.log (81.5 KB)

There’s a typo in the Octopus config in the Klipper repository. The enable pin on the driver socket you’re using for Y should be inverted. Try changing PA0 to !PA0.

Figured it out. Per usual I’m just a dumb dumb, when I flashed the firmware on the MCU I didn’t select the correct clock speed. Flash with the correct clock and it’s working fine now.

1 Like