"MCU 'mcu' shutdown: Timer too close" when homing

Basic Information:

Printer Model: Voron V2.4r2
MCU / Printerboard: Octopus V1.1 (F446, Pi4)
klippy.log (82.6 KB)

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
Be sure to check our Knowledge Base and in particular this and this post

Describe your issue:

Started having some issues with first layer being uneven, Y+ perfectly lay down, X+, Y- and X- looked like Z lifted, then on Y+ movement all good and repeat.
Reinstalled and reflashed according to Voron docs, now I can not even home any axis.
Stepper buzzing ok. MCU shutdown right after Z lift to home X.

Different Pi board tried, nothing connected tried. I do not get any further.
Broken hardware? Bad stepper drivers?

Hello @zChilliz !

You may have a look here:

And also try decreasing the homing seed.

I have looked through that one. New fresh installs have been tried. Multiple SD cards.
Fresh printer config, even my backup that was working before this happened. Also now tried lowering homing speeds and run currents. No luck.

Oh, I missed the advanced trouble shooting section so I will be going through that one.

1 Like

Lowering those should not effect on Timer too close. In opposite: You can lose steps.

Well, trying just about anything and everything at this point. And I kind of increased them a little bit to gain accel from previously. Trial and error so to say :slight_smile:

And making graphs of the log did not help much. No sudden spikes. Barely any spikes. So now, I am going through wiring and rest of the hardware to find something or anything. Funny how it works one day and the next just nope. The more I troubleshooted, the worse it got.

Continuing on, not giving up hope. 9 days and counting now…

What type of probe do you have?

Voron TAP with Fermio Labs OptoTap PCB 12/24V

Fermio OptoTap PCB

System load looks quite high (can be plotted with scripts/graphstats.py -s). Have you looked with htop if you have other process consuming CPU?

Do you have other logs reproducing the failure? This one is quite short.

That appears to be a regular optical endswitch, but not a probe.

Well then I must be misunderstanding what you mean with probe. Regular Z endstop behind the bed and inductive probe in toolhead is replaced with the TAP.
What other probe there could be I do not know.

Sadly no. I have reinstalled Mainsail and reflashed the firmware on MCU, so basically all history is gone. Yeah, I made the mistake of not downloading the log before I did this :frowning:

I still have a lot to learn I see, mistakes have been made.

1 Like

Then you have to correct the settings in stepper_z

step_pin = PF11
dir_pin = PG3
enable_pin = !PG5
rotation_distance = 40
gear_ratio = 80:16
microsteps = 32
endstop_pin = probe:z_virtual_endstop    # <------------------------
position_max = 315
position_min = -10
homing_speed = 10
second_homing_speed = 5
homing_retract_dist = 5

Umm, that setting is done according to Voron instructions.

Copy/pasted from their GitHub:

Update your Z endstop:

  • Under the [stepper_z] block, you’ll want to comment out your position_endstop and change your endstop_pin so that it uses the virtual Z endstop for Tap.
    • Example: endstop_pin: probe:z_virtual_endstop

Ok, forget this. I’ve got new information.

[quote="zChilliz, post:13, topic:9231"] `endstop_pin: probe:z_virtual_endstop` [/quote]

That line is for proximity sensitive probe, not an endstop switch.

Can you please post the link where these instructions are?

And a little update and in case anyone else makes the silly mistake I made.

Considering the 2 versions of the Octopus board (V1.1 and Pro) using different frequency crystals for the clock, make sure to select the correct one for your board or the fault in the title will be the result.
Yup. I accidentally chose the wrong one, several times.
Note to self: RTFM, slowly.

Thanks for your time and help ladies and gents in this matter. Much appreciated.

1 Like

You have to know what CPU is being used on the board.
My Pro with H7 is not mentioned in the manual but on other sources.
Shame on BTT for not being up to date with their stuff.

How/where do you set the frequency crystal for the board? I think I might be having the same issue.
EDIT: never mind, it looks like I have it set correctly (12 MHz).