Extruder issues

Basic Information:

Printer Model: tronxy x5sa
MCU / Printerboard: manta m8p
klippy (8).log (3.1 MB)

I am getting the shut down “DRV_STATUS: c0190010 s2vsa=1(ShortToSupply_A!) cs_actual=25 stealth=1 stst=1”

I have tried to move the driver to a different slot & got the same shutdown. When I tried a different stepper motor I didn’t get the shutdown but it didn’t move either. I am super new to this.

You already opened a thread on that issue.

A second one doe not give faster answers.

There is different info on this one it’s not the wiring the motor not turning when swapped and I was given no real actionable information. I did the suggestion and didn’t do anything.

However, with both cases you got a short circuit reported.
Check your wiring from the board to the steppers.

You have three options for this kind of error:

  • Bad stepper
  • Bad stepper driver
  • Bad wiring

I swapped the stepper driver with one I know works, tried a different stepper and changed the wire. still getting the same thing. any suggestions?

The error means that an over-current condition was triggered when the driver tried to pull the motor-coil to GND with the MOSFETs. That is usually an indicator that the coil is shorted to the 12/24V rail.

This error message is not generated in Klipper but in your TMC driver internally and Klipper is just reporting it.

The only option missing from the list above is a defect or dramatic misconfiguration of your Manta board. It is definitively a hardware thing and needs to be fixed on hardware level.
I do not know this board but a quick look through the manual revealed that there are two motor ports labeled 3A and 3B. Make sure not to connect two different steppers to these two ports.

not useing 3A or 3B I heard that those cause problems.

i have tried both stepper 06 and 08

You are using a BTT Manta M8p V 1.0?

BTT Manta M8p V 1.1 .

Does that one has a different pinout than the 1.0?

Because steppers X,Y Z and Z1 fill well to the 1.0 pinout.

The rest is very different.

I just tried 07 same results. I believe the pinout is the same. they share a manual. double checked. It’s set up as in the manual.

So, referring to this:

and your klippy.log:

As said: X (M1),Y (M2), Z (M4) and Z1 (M5) the assignments are ok.


Assuming the extruder is M8

step_pin = PA10              # this is STEP M6, should be PD10 STEP M8
dir_pin = PC6                # this is control of RGB1, should be PD8 DIR M8
enable_pin = !PC7            # this is CS (UART) M8, should be PD9 EN M8
microsteps = 16
rotation_distance = 35.520
nozzle_diameter = 0.4
filament_diameter = 1.75
heater_pin = PE3         # this is HE0, is ok
sensor_pin = PA0         # this is THB, should be/recommended PA1 (TH0)
sensor_type = ATC Semitec 104GT-2
control = pid
pid_kp = 18.831
pid_ki = 0.821
pid_kd = 108.044
min_temp = 0
max_temp = 250

[tmc2208 extruder]
uart_pin = PD10     # this is STEP M8, should be PC7 CS(UART) M8
run_current = 0.800
stealthchop_threshold = 0

heater_pin = PE1           # this is HE3, should be PB7 (BED-Out) because the MOSFET can do more amps
sensor_pin = PA1           # this is TH0, should be/recommended PA0 (THB)
sensor_type = EPC OS 100K B57560G104F
min_temp = 0
max_temp = 130
control = pid
pid_kp = 73.932
pid_ki = 1.521
pid_kd = 898.279

[heater_fan hotend_fan]
pin = PE0                 # this is FAN1, should be/recommended PE6 (FAN0)
max_power = 1.0
fan_speed = 1
kick_start_time = 0
heater = extruder
heater_temp = 50.0

pin = PE6                 # this is FAN0, should be, recommended PE5 (FAN3)
cycle_time = 0.0001
hardware_pwm = False
kick_start_time = 0
off_below = 0.05

kinematics = corexy
max_velocity = 300
max_accel = 3000
max_z_velocity = 25
max_z_accel = 30

sensor_pin = ^PB2        # this is ok
control_pin = PB1        # this is ok
z_offset = 4.000

You have to do some rewiring

thank you . now I am getting “Unable to read tmc uart ‘extruder’ register IFCNT”
I double-checked the board everything is plugged in.

Have you set that jumper?


You can also try by swapping the stepper module with another one.

Yes to the jumper. I have tried other steppers but I might have miss set the config.

I had this issue and it turned out 3 of the TMC2209 V3 I was using were bad. Problem was solved by replacing with surplus V2.

1 Like