Stepper motors acting strange on new board

Basic Information:

Printer Model: Originally an Ender 3 (the first one) but only the frame remains
MCU / Printerboard: Manta M8P v2.0 with CB1 eMMC
klippy.log (196.5 KB)

Describe your issue:

I had a Manta M8P that I liked, but I accidentally damaged it somehow. So I bought a new one (which ended up being the 2.0 version instead of the 1.1 I had previously). I also saw they had a newer version of the CB1 with eMMC so I got that too. I reused the old stepper drivers, which are TMC2209s. I followed the instructions to put the jumpers. I also followed the instructions to the letter on installing Klipper since the eMMC thing was a bit strange to me. I then made sure to move one wire at a time, writing down what spots I plugged them into. As far as I can tell after repeatedly double-checking, every jumper is in the correct location and every wire is marked correctly in the printer.cfg file. I also copied all my existing macros from a backup.

Everything else I tested out worked fine … but the motors are acting strange. If I have the TMC settings active (remove the comment symbol), then if I attempt to home any motor at all I get a shutdown with a similar message, for X it is “unable to read tmc uart ‘stepper_x’ register ifcnt”. If I put the comment symbol back, and make sure everything else is correct, then when I try to home anything other than Y it engages the motor so I can no longer spin it by hand, until it times out because the endstop was not pressed. The Y motor goes the wrong way but it does move. If I reverse the direction setting (remove the ! symbol on the “dir_pin”) on any motor including the Y, literally nothing happens. It doesn’t go the wrong way. It doesn’t lock the motor like it’s trying to move it. Even with my hand on the motor I feel nothing happen.

I do not have other drivers to plug in and test, but I have tried inverting the step_pin, inverting the enable_pin, every combination I could think of with inverting or not inverting the pins, I tried using other motors, other wires, removing the jumper, putting the jumper in a different location, swapping the wires… that time the X moved (the wrong way) when I told it to home Y with the normal settings, but did nothing when I inverted the direction.

When I was trying to download the klippy.log file I accidentally deleted it instead so I re-ran the issue with TMC settings, without TMC settings but normal regular settings, and without TMC settings but inverted direction. Hopefully that will be enough to see what’s going on. There was a single time I managed to get the Z to attempt to home, but it didn’t stop even though both endstops were triggered, until I finally hit the restart button. That was before the accidental wipe, though. I still haven’t figured out if both motors moved, only one moved, or they moved in opposite directions.

You need to solve this issue. There are just enough threads here, e.g. Driver coms error - #21 by Sineos that deal with this.

And you need the proper TMC sections, otherwise your setup will never work properly.

Why did you delete your post?

Good luck, hcet14

Sorry, pressed the wrong button. I was trying to edit it.

I originally had said I discovered my PSU was only producing 18.2V instead of 24V to the motors, so I purchased a new one.

Well, that didn’t work. I also tried starting over with a fresh (non-updated) install to see if that helped. It did nothing either.

If I invert (remove the !) the enable_pin it causes the motors to engage (unable to move them by hand) until it tries to tell them to move, then they disengage and don’t do anything, until it times out because the end stop was never activated, then they return to enraged and unable to move by hand, so they definitely do have power.

Somehow the problem lies in the communication with the drivers. But the same drivers worked perfectly on the old (v1.1) M8P board, so I don’t understand why they’re not working on the new (v2.0) board. All the other things I can see (and understand) of things other people did to fix their machine doesn’t apply to me. I have a separate set of wires from the PSU to the Motor In spot, and I have the jumpers set to HV. I did try switching the jumpers to VBB and that made no difference.

See GitHub - bigtreetech/Manta-M8P

  • Make sure to have a correct config according to examples in the above link
  • Make sure to have to board jumpered correctly according to the instructions
  • Check proper seating of the modules
  • Check proper wiring and motor connectors

If all points are triple checked then it could be a dead stepper driver.

I copied the config from there, making only slight changes based on my old config that I had a backup of, such as switching the rotation_distance for stepper_x to 19.965 instead of 40 (I have 0.9° motors on X and Y)…

The only part of the original board (other than the wires) that I reused was the stepper driver chips (well, technically the motors too, but I still had the old ones that came off the original Ender 3 that I could test and got the same results so I know that’s not the problem), with the thought that a fan short shouldn’t cause a driver to be damaged, but after trying everything else (even replacing the PSU and wires), I decided I would try replacing the drivers. I didn’t have any extras to test out (the original board has them soldered on), so I have ordered a new set (of 5, but I only have 5 motors so it’s fine for now). I really hope this works, because I’m about to just chuck the entire thing out the window at this point.

I think you detected your problem. 18.2V vs. 24V is a significant drop. The energy has to go somewhere, usually heat. I would touch every part of your printer which is electrified.

Or disconnect components one at a time and measure your PSU voltage all the time. If it goes back to 24V you may find what’s wrong.

It turns out the TMC Driver chips were indeed bad. All of them. I got a new set, and tested each one one at a time. All the new ones work great, all of the bad ones gave me that error message. Apparently when I shorted the fan the feedback not only damaged the main board but every driver at the same time. Thanks everybody for your help. I’m just glad to have a functioning printer again.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.