BIGTREETECH Manta M5P + CB1 + 5xTMC2208 Cant get steppers to move

Printer Model: Creality Ender 3 v2
MCU / Printerboard: BIGTREETECH Manta M5P

Hi guys,

i recently got myself a M5P + CB1 + 5xTMC2208 combo, i set everything up, got into klipper and everything seems to be okay so far, but i cant get the steppers to move. When i do the BUZZ test from the klipper configuration guide, klipper says busy for a few seconds, but nothing moves or makes a sound. Bed and Extruder heat up so there is enough power on the board. Did anyone run into that issue before or has some advice for what to do?

Thanks in advance!

klippy.log (247.7 KB)

On a brief glance there are some “issues”:

AH alright, well that makes sense. The whole drivers stuff is really confusing to get into tbh. I have seen the TMC2209 section in the cfg but since there werent any 2208 references i thought they might get detected automatically or whatever.
Also i didnt know that KAMP works out of the box now.
I will try to fix that stuff and report back wether it worked or not!
Thanks you very much already!

Okay now im a bit further into it, i’ve added the section for the drivers:

[tmc2208 stepper_x]
uart_pin: PD9
run_current: 0.800

[tmc2208 stepper_y]
uart_pin: PD8
run_current: 0.800

[tmc2208 stepper_z]
uart_pin: PB10
run_current: 0.800

[tmc2208 stepper_z1]
uart_pin: PB2
run_current: 0.800

[tmc2208 extruder]
uart_pin: PA6
run_current: 0.600

but now when i try the stepper buzz command klipper shuts down with the error:
“Unable to read tmc uart ‘stepper_x’ register IFCNT”

I’m currently investigating whats the issue, but if anyone knows whats up with that before i get to the solution i would appreciate the knowledge. I will keep this thread updated with my progress.

Make sure that

  • You have correctly jumpered the board to use UART
  • You have correctly jumpered the board for the relevant “Driver Voltage Selection”
  • You have correctly inserted the driver modules

Refer to the instruction manual for details: Manta-M5P/BIGTREETECH MANTA M5P V1.0 User Manual.pdf at master · bigtreetech/Manta-M5P · GitHub

yeah i have been looking at this manual for like 3 days at this point. all of the points you mentioned have been double and triple checked already. I also tried high voltage and board power setups with their respective jumpers but nothing changed. I have been watching various youtube tutorials aswell to maybe pick something up which i might have messed up, but i couldn’t find anything up to this point. I’m considering ordering another board to be able to cross test if anything is faulty together with some 2209 drivers since i really like the idea of not needing endstops.


Have you ever check the motor cables? sometime they can be misconfigured and miscabled

Have you installed a power jumper for the drivers on the board?

The reasons for this kind of error are:

  • Wrong pins assigned to UART → Check against example
  • Wrong UART jumpers on the board → Check against manual
  • Wrong VCC of the drivers → Check against manual, check wiring
  • Other UART devices “hogging” the bus → Check schematic if bus is shared / simplify setup as much as possible, i.e. remove displays, no fancy sensorless homing (check jumpers!) etc.
  • Driver module incorrectly installed
  • Dead driver module(s) → Swap drivers

Yes i have, i have tried 4 different variations and none of them worked. the variations i tested were: ABCD, DCBA, ACBD, DBCA. At least one of them should have made at least a sound or something buut no, as soo as i send the stepper buzz command klipper shuts down with the error.

yes i have tried both variants.

I will answer this step by step and in as much detail as i can, since these are all points i already checked…

  1. UART PINS: X: PD9 Y: PD8 Z: PB10 Z1: PB2 E: PA6

  2. The Jumpers on the board are set like this:

  1. The only things i have installed on the boards are the two thermistors of bed and extruder, two endstops for x and y, and the drivers + wires for the drivers.

  2. Red on Red, Black on Black, all pins in their sockets.

  3. Did that too. Itried every driver i have on x and sent the buzz commands, same outcome with every driver.

At this point i really suspect something is dead tbh…

Unfortunately, I cannot offer any more guidance than the above.

As a last resort, you can try reflashing your board and triple check that all settings, especially MCU processor type and Clock Reference, are matching to the requirements.

I really appreciate your help anyway though! Thnak you very much for it so far! I will reflash it, report back and if everything stays the same i will just order a new one…

Can you send back the error??

what do you mean with send back the error?

Board has been reflashed, error persists. New board arrives tomorrow with some new tmc2209 drivers. hope this fixes it.

Could you post a picture of your TMC2208 driver modules and indicate who manufactured them?

I’m wondering if your problem is a simple as there aren’t the UART pins soldered into the driver module.

1 Like

Excellent input. Another issue could be a missing solder bridge on the backside of the driver module.


Only relevant is “Step 1: Modify Your Driver Modules…maybe” and maybe “Step 2: Modify Your Driver Modules (part 2)”. Disregard the rest.

1 Like

According to the article my drivers dont need any modification.