Geeetech Mizar S error Endstop y still triggered after retract

Basic Information:

Printer Model: mizar s
MCU / Printerboard:
klippy (2).log (686.2 KB)

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

Hi people i am new to this forum and this is my first post
I got myself this 3d printer Geetech Mizar S, I am not new to the 3d printing side of things been doing it for the better part of 4 years now however i have been use to Marlin and altho the printer can run that when i saw that it could use Klipper i thought well its a new challenge, got the printer.cfg off Geeetech github site got it connecting etc etc now when i click the home button its moves the print head up slightly then right to left home the when it comes to move the print bed it does move a bit (in the wrong direction its coming out towards the front of the printer instead of going back) but then stops with the error Endstop y still triggered after retract, the print head heats and so does the print bed its just this print bed homing issue… i did try a replacement sensor of the bed homing but gives the same error.

i tested the printer with the default marlin software and it homes and prints without any issues

I did do a quick search for this but can not find anything.

its running the interface off Rasberry Pi 4.

Anyone can help me please ??

Thank you

Work through verify-endstops to ensure basic functionality and then we work from there

1 Like

Sineos thank you for the replay i read the verify-endstops took out the ! on the y endstop and it homes great now thank you… i will finish off testing now then try a test print

Hello badwolf, is klipper working correctly on your mizar S? I’m also trying to install klipper on my mizar S but so far it’s not a success. I had the same problem as you with the motor y now everything is ok for the house but not for printing. when I start a print the printer goes to the right/back corner and does nothing else. Also, my part fan is not detected by Klipper.

Hi Sol-Invictus yes mine is printing , mine does that on first print do not know why, but its just paused if you look on the web interface its just paused press the resume, mine does not see the fan either but it still spins the fan up.

Sol-Invictus, I am not sure if your still working on this but to stop the pause you need to add CLEAR_PAUSE to your slicer start code that will stop the hotend from parking to right and pausing.

Also i have issues with my prints been off center and no matter how much x or y offset i put on them in printer.cfg i could not get it to move, in the end i used the slicer to alter the nozzle offset by 5.5, altho this method i think i am loosing some print area but its a solution for now.

Also because of the above issue i had to alter the slice code for printing the blob line at the start of each print here are my current settings hope they help

G1 X9.1 Y20 Z0.8 F5000 ; Move to start position (use to be X0.1)
G1 X9.1 Y200.0 Z1.2 F1500 E30 ; Draw the first line (use to be X0.1)
G92 E0 ; Reset Extruder
G1 X9.4 Y200.0 Z1.2 F3000 ; Move to side a little (use to be X0.4)
G1 X9.4 Y20 Z1.2 F1500 E25 ; Draw the second line (use to be X0.4)
G92 E0 ; Reset Extruder
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X5 Y20 Z0.4 F3000.0 ; Scrape off nozzle residue

if anyone else reading this has a better solution please let me know thank you

Okay, thanks, I’ll give it a try.

For the fan, I have the beginnings of a solution. In my case, the extruder fan was always running at 100% and the parts fan started when the hotend was over 50°, so I commented out all the line [heather_fan hotend] and activated the fan line with the PE1 pin.
Now the extruder fan is always at 100% all the time but I have control over my
parts fan.

Thanks for that Sol-Victus, However when i do what you did only filament cooler is controlled the fan on the left side of the print head is not working at all which is odd because both fans do come one at a given temperature with the default setting, I have tried looking through Marlin source code to see if i can find the pin out for the fans but so far its eluded me.

Sorry my mistake i had taken the cover off and failed to plug the fan back in lol

I came across this issue myself, and i see the marked solution does not give a solution at all.

But I did find the solution so i will post it here for others

on the Y endstop in printer.cfg provided by Geeetech they have inverted it.

You need to remove the ! for it to report as open

Incorrect config entry:

step_pin: PA2
dir_pin: PA1
enable_pin: !PC13
microsteps: 16
rotation_distance: 40 #
endstop_pin: !PB3
position_endstop: 0
position_max: 255
homing_speed: 30

Correct Config entry:

step_pin: PA2
dir_pin: PA1
enable_pin: !PC13
microsteps: 16
rotation_distance: 40 #
endstop_pin: PB3
position_endstop: 0
position_max: 255
homing_speed: 30

The specific entry is bellow:

endstop_pin: PB3

Hello @Silverfox0786

You have seen the link in that post?

If the OP worked through that guide and came to a solution, then it is the solution.

You may consider to have a different solution.

@badwolf Hello, how did you get Klipper to run on the Mizar S? I can’t get a connection to the printer?


U. Haas

Hi UHas, did you download the firmware from github for the Mizar? if you trying to make your own from command line mine never worked i had to get the firmware from github… i am not sure if i am allowed to post URLs so you will have to do a google search for it.

UHaas it would be helpful if you explain how far you have got and what exactly you have done

Thanks see my problem

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.