Help With My Issue Please

Basic Information:

Printer Model: Ender 3 Pro with CR-Touch
MCU / Printerboard: SKR Mini e3 v3.0
klippy-2.log (13.8 KB)

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

I have my klipper log attached. I am confused, the printer config file in mainsail does not seem to exist. The ls /dev/serial/by-id/* command doesn’t work it just says “No Such File Or Directory” on the ssh terminal. I am plugged in to my 3d printer for sure though and its not a problem with the usb cord.

I tried both the settings that my specific board has and the settings the printer.cfg example had.

your log state that klipper is trying to load config but it’s mising:
file should be here:


it’s because you klipper is started with this arguments:

Args: [‘/home/pi/klipper/klippy/’, ‘/home/pi/printer_data/config/printer.cfg’, ‘-l’, ‘/home/pi/printer_data/logs/klippy.log’, ‘-I’, ‘/home/pi/printer_data/comms/klippy.serial’, ‘-a’, ‘/home/pi/printer_data/comms/klippy.sock’]

If file is there - check owner of the file and its permissions

I don’t think it is their, its definantly not in mainsail config files. Every time I try to add a config file from the mainsail page it won’t let me. I also cant seem to find the port for the connection, even with the ls /dev/serial/by-id/* command

You did send klippy log file, log did state that it don’t see config file and where it did search it, also log state which parameters was used to launch a klipper - that’s is you source of truth.

Mainsail - is just a client of klipper.

Go and manually put config file in that place, then restart klipper and look at logs.

Where would i put the file in the klipper sd card? also does it matter that i have a different driver and no bootloader then the config file for that board has? here is the err message

I tried throwing the skr mini e3 v3 file in the sd card and it didn’t seem to work

Thank you for your help

Ok, first of all go and read following topic to get understanding about each part of your system and how it’s working together and where each part of it is located.

If you read it then now you should understand that MainSail is just last peace of puzzle. And we should concentrate on the “host”.

Judging by path names - most probably you have Raspbery PI there and most probably it’s task to run Mainsail + Moonraker + klipper “host” + Linux Virtual MCU(optionaly).

If I did describe your system right - then you need to use SSH and login to your raspbery, then go to that place where “printer.cfg” should be and check if it’s there.

Ok i figured out the port and how to flash the firmware. After i did that though i now get a screen on mainsail that says Startup: Starting up-Try in a Few moments. and then says mcu err
Then i get this err on ssh when running a mcu testing command
Failed to start klipper-mcu.service: Unit klipper-mcu.service not found.

Thank you for helping, Ik I’ve been confusing and probably sound really stupid at times. :rofl:

That’s normal for newcomers.

Ok so if you have error about “klipper-mcu” - then this means your “Linux MCU” is missing.
“Linux MCU” - i’m calling it “Host virtual MCU” - to reflect it’s true nature.

To build it and to deploy it - you need to do similar steps as for firmware build process
you can read how to do that here: RPi microcontroller - Klipper documentation

If you need optional stuff mentioned there - skip it for now, later you can return and finish it.

IDK how but it all works now.

THX for helping

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.