Help with sensorless homing and pinda probe

Basic Information:

Printer Model: x5sa frame
MCU / Printerboard: skr mini e3 v2
klippy(10).log (1.1 MB)
printer-cfg .txt (12.3 KB)

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
Be sure to check our Knowledge Base and in particular this and this post

Describe your issue:Can someone check out my cfg and log file, Trying to set up sensorless homing and have searched the forums for the last 3 days.

sensorless homing on x and y . Pinda probe on z

x reports “Endstop x still triggered after retract”

issue G28 command for z and also get Endstop x still triggered after retract.

At first glance, your driver_SGTHRS value is very high for your X axis (which is what I presume you are trying to home first). What values have you tried for it?

Could I suggest that you work through a binary search approach to finding the right value? Start with 120 and if the problem persists, go to half the value (60) and run it again. Depending on what happens, go half the distance (to 90 or 30) until you have something that’s reliable.

Good luck!

I have worked down from 250 down to 60 and the motor grinds when it bumps, all sensors report as open

What happens if you increase the run_current? You have it set to 0.5 right now which seems a bit low. I’m also not sure about your use of 32 for microsteps.

Could you try again finding the right driver_SGTHRS with the run_current set to 0.7 or 0.8? As this is a CoreXY system, you need to change both the x and y run_current values. You might also try it again with 16 for microsteps.

What is “sensorless.cfg”?

If you wish to use sensorless homing you need to disable the second homing attempt (homing_retract_dist: 0) - be sure to follow the directions at TMC drivers - Klipper documentation