Issues with fresh install

Hi guys, I just set up a fresh Mainsail setup for my Ender 3 V2. I got the KlipperScreen package installed and it GUI came right up however the touchscreen wouldn’t work at all.

Mainboard is a Creality 4.2.2 and the touchscreen is a 7" RPi unit on a 3b+.

Now I can’t get the GUI to come up at all, all I see on the screen is it asking me to login. No matter what autologin method I choose it won’t boot into KlipperScreen at all anymore.


have the same issue with ELECROW 7" . only shows the login on screen

i installed Mainsail with thair own OS und klipperscreen.
checked the installation of klipperscreen with an android smartphone and that worked but sadly the Display not

hope anyone could help us

1 Like

Made it finaly

execute following command on console

sudo bash -c “echo needs_root_rights=yes>>/etc/X11/Xwrapper.config”

I was in the same boat and tried every fix with my gpio mhs3508 screen. The solution that worked was using an older (buster) based install. I could do the same steps as below with bullseye and couldnt get past the console…

For future me to refer to:

Install buster 32bit via raspberry pi imager
Install lcdshow (at 270 degrees)
Install kiauh
Install, klipper, mainsail, klipperscreen, crowsnest
Run lcd calibration

Hopefully someday whatever issue is blocking my lcd is resolved in bullseye…

i tried that and i get permission denied