Klipper keeps rejecting my mcu

Basic Information:

Ender 3 v2
MCU / Creality v4.2.7

klippy (5).log (140.3 KB)

Describe your issue: Hello, so I’m a newbie to klipper and I have a problem that has been driving me up the wall.

so first i get this - Printer is not ready
The klippy host software is attempting to connect. Please
retry in a few moments.

then maybe a few minutes later i get this - mcu ‘mcu’: Unable to connect Once the underlying issue is corrected, use the “FIRMWARE_RESTART” command to reset the firmware, reload the config, and restart the host software. Error configuring printer

my MCU id is this - /dev/serial/by-id/usb-1a86_USB_Serial-if00-port0

I have no idea why it’s rejecting my MCU I’ve been through 2 tutorials with no luck running off of a raspberry pi 4.

Likely your board is either:

hello, thank you for the reply I took a look at it again just as carefully as i did the first 2 times and everything looks the same, i will provide the screenshot of my config and what i have to set for my printer next to each other.

hello i feel stupid on how easy the solution was i was changing the .bin file to firmware but i tried it again but just leaving it as klipper.bin and it worked.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.