Klipper not loading

Basic Information:

Printer Model: Ender 3 (original)
MCU / Printerboard: Creality V4.2.2

Hello! I’m a newbie to computer programming and 3d printing. I was able to load Klipper to a BTT Pi v1.2 and have been using it on my ender 3 for the last 6 months without issue. All of a sudden my klipper will not start. I literally printed a file on Saturday and then Sunday when I went to fire up the printer my MCU appeared to power on (my BLtouch cycled) but klipper never loaded. Nothing had changed in my config that I was aware of, but I can’t even access it to post my log or see what’s going on. I’m not sure if my SD card is corrupt or my BTT Pi crapped out. I’m not sure what I should do now. I can’t SSH into my BTT Pi because it won’t even boot. I tried connecting my Pi to a monitor and the BTT splash screen comes up, but just sits there forever. Be gentle, I’m trying to learn from scratch. I do not have a computer or IT background and have VERY little linux experience or skills. I’d be glad to answer any questions I can. Thanks it advance!

It would have been a start to answer to the requirements of the template when you opened this post → klippy.log
Or do you try to challenge our psychic abilities to know what’s wrong from the description of “worked one day but stopped the other”?

1 Like

How can I upload a klippy log when I can’t even get klipper to load? I uploaded all the information that I can actually physically access. If you have a way for me to access the klippy log without being able to load klipper then please let me know how and I would be happy to upload it.

How do you power down the BTT Pi?

Please distinguish between the BTT Pi OS and Klipper. If Klipper is not loading (your thread title) the OS may. But it seems your OS is broken. And if you can’t successfully boot, you may have to start from scratch.

Hint: Use a new SD card. You may can read old data (like the printer.cfg) from the broken card withe a Linux PC.


BTW: Less words are more easy to read. Some things you wrote wont help to find the issue, but prevent supporters to read all (TL;DR)

1 Like

Thanks Eddy, I tried a fresh install on a new SD and it worked. My SD card was corrupted because of my powering off the PI but turning off the power. I’ve started using the shutdown host button in mainsail to hopefully prevent the SD card from becoming corrupt in the future. Lesson learned to always back up my printer.cfg once I’ve got a good working setup…

1 Like