Lost communication with MCU 'mcu'

Hello everyone,

I have been having a very hard to diagnose problem, I have a ender 5 with the Creality 4.2.7 board and as raspberry PI 4I am getting this problem:

And on dmesg:

[ 2770.793730] ch341-uart ttyUSB0: usb_serial_generic_read_bulk_callback - urb stopped: -32
[ 2781.794698] ch341-uart ttyUSB0: usb_serial_generic_read_bulk_callback - urb stopped: -32

my lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
Bus 001 Device 004: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 001 Device 003: ID 046d:081b Logitech, Inc. Webcam C310
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I am running l klipper commit db5a4351a5d580563fa4c0323997a4f48bfe120d

So far to mitigate the problem I have tried:

  • Change the power supply of the Pi
  • Other PI
  • Update raspberry pi firmware
  • Change USB Cable
  • Wrapped the USB cable in aluminum tape (this actually helped for a few days)
  • Tried downgrading to usb 1 with ``dwc_otg.speed=1t
  • Did several updates to all the systems.

So far no nothing that could help me diagnose the problem further. I think the only thing I have to try is set up serial communication, but I have no idea where to connect to the board, according to the klipper config example you can do it, but I have no idea what those pins are mean.

Here is my klippy.log, with the error:

Loaded MCU 'raspberry' 107 commands (v0.10.0-450-gdb5a4351 / gcc: (Raspbian 8.3.0-6+rpi1) 8.3.0 binutils: (GNU Binutils for Raspbian) 2.31.1)
MCU 'raspberry' config: PCA9685_MAX=4096 ADC_MAX=4095 PWM_MAX=32768 CLOCK_FREQ=50000000 MCU=linux STATS_SUMSQ_BASE=256
mcu_temperature 'mcu' nominal base=357.558140 slope=-767.441860
MCU error during connect
Traceback (most recent call last):
  File "/home/pi/klipper/klippy/klippy.py", line 180, in _connect
    cb()
  File "/home/pi/klipper/klippy/mcu.py", line 723, in _connect
    config_params = self._send_get_config()
  File "/home/pi/klipper/klippy/mcu.py", line 710, in _send_get_config
    self._name,))
error: Can not update MCU 'mcu' config as it is shutdown
Build file /home/pi/klipper/klippy/../.config(680): Mon Jun  6 20:57:09 2022

Any sugestions would be welcome

I’m having the same issue. It disconnects with a “Lost connection to MCU” error even when i just leave the printer turned on and not printing anything.

I tried a few different usb power supplies. Tried different cables. Taped off the 5v output in usb cable. Recompiled and reflashed klipper.

Hi,

same situation here. Printer is a Voron Trident with a Raspi 3 B+. The strange thing I’ve noticed, that after this crash my USB camera doesn’t work anymore until it reboot the pi.

Attached the log:
klippy (6).log (1.4 MB)

After several trials I could locate my problem as an issue with the USB host controller. It just couldn’t keep up with the camera plus klipper. Since I disconnected my camera I didn’t have a single issues anymore.

Elims, I have the same problem and it’s no issue when I remove the USB camera. Do you think a raspberry 4 would solve it? Tried to find if it has a more powerful hostcontroller but wasn’t able to find any information about that…

Haven’t tried yet. But most people don’t seem to have this problem. But raspi’s are kind of unobtianium at the moment.

Yeah, would be interesting to try but just noticed thread starter here has a RPI 4 and also has the same issue…
Wonder what is common with our setup that creates this problem. Sometimes even my raspberry crashes, does not seem to matter if I print or not. If I unplug the camera all is fine again…

Elims, I borrowed a raspberry 4b from another project, and it has been running fine now for over 24 hours, so I really think it solved it, at least for me.

Then I’ll need to look into my boxes if I can find a raspi 4.

I am struggling with the same issues. Ender 5 Pro with 4.2.2 board, and an RPi 4. Usually within 1 day it will throw an MCU communication error (even while idling, not printing). Lately my prints are failing within a couple of hours at seemingly random moments.

I have tried:

  • Multiple quality USB cables, including shielded ones with magnetic ring EMI noise suppressors.
  • Different USB ports on the RPi. USB2 and USB3.
  • Disconnecting +5V on the USB cable to the printer.
  • Updating all software/firmware
  • Physically locating the RPi 4 and the USB cable away from the printer (as much as practical).
  • Using a UPS power source
  • An RPi 400, and new microSD card

I realized one possible source of EMI could be my USB camera which was mounted on top of the printer. I have tried relocating that away from the printer as well and am currently doing a print to see what happens.

Getting frustrated! Debating if I do a rebuild with UART using the LCD display pins. Haven’t found a decent idiot-proof guide for that though. And I enjoy having the LCD screen. So might need to go down the rabbit hole of Klipperscreen too. Grr.