MCU unable to connect, ls: cannot access '/dev/serial/by-id/*': No such file or directory

Basic Information:

Printer Model: Vivedino Troodon 1.0
MCU / Printerboard: PI4b, BTT Ebb 42 1.1
klippy(5).log (416.5 KB)

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

… My setup was working until I decided to click update all in Mainsail, and ran into a bunch of errors needing to reflash the EBB42 board. This was late last year, and I am just now getting time to work on this. So I started over from scratch, flashing the EBB42 board, then reinstalling Klipper onto the PI. I got the EBB board updated, but am now running into: ls: cannot access ‘/dev/serial/by-id/*’: No such file or directory.

I have scoured these forums, and other online sources, for other solutions that have worked for other people, but none of them are working for me. I’ve spent 3 days on this so I would not even know what all to say that I have tried. I’m hoping someone can look at the attached log and have a better idea.

I am at the point if I cannot get this to work, I am looking for recommendations on what to completely upgrade the main board to so I do not have such a hard time trying to get everything updated. Currently looking at the Octopus Pro or the Kraken. I’d still like to be able to use the rest of the electronics, but am willing to change anything out just so I can use this printer again.

[mcu head0]
canbus_uuid = 6d30486916f0

Your main mcu can’t have an alias, change it as shown below and it should work.

canbus_uuid = 6d30486916f0

The main mcu has no alias:

serial = /dev/serial/by-id/usb-Klipper_sam4e8e_003230533553504E3033303135303132-if00

[mcu rpi]
serial = /tmp/klipper_host_mcu

Sorry you’re right, I didn’t scroll down far enough and missed the second portion.

@Recoil1980 - I’m not familiar with the Troodon or it’s board, but that’s the one that’s having trouble connecting not your EBB42. Did you reflash your Troodon with the newest Klipper when you flashed your EBB42? If so, I’d start simple, check your Troodon board is getting power, check the USB cable and swap it with another known working cable (Assuming it’s USB and not serial connected).

I don’t know why it would, But you might connect to your Pi via SSH and run the

> ls /dev/serial/by-id/*

Command and make sure the serial ID didn’t change for some reason.

According to your log, the problematic part is the [mcu], i.e. the Troodon printer board.

Follow the hints given in Issues flashing the printer board

Thank you for the info guys!

I went through the steps from scratch and keep getting the same issue:
ls: cannot access ‘/dev/serial/by-id/*’: No such file or directory

A friend who is assisting me sent me this link, which finally helped me get past that error:

However, then it could not find my EBB42 board. So I resolved that issue and now am getting the same mcu unable to connect error.

I have went through this from scratch several times, and even swapped out the USB cable with a know good one to rule it out.

The troodon board is a duet clone, and from what I understand debian 11 (bullseye) is having issues with the duet boards. I tried to manually update to debian 12 (bookworm) but I am still running into the same issues.

I think my best bet at this point is to rule out the mainboard and swap it out to one known to work. Any suggestions on a good replacement board?

Honestly, with Klipper, most Mainboards are as good as another (I’d avoid an 8-bit board). It’s more often about what features you want on the mainboard more than if one is “better” than another. Number of stepper drivers, easy connection for an external screen, how many fan connections you want etc.

An actual Duet board is pretty good but pricey, Mellowfly boards are actually pretty good quality but not often found in the U.S. at least, you’d have to order off Aliexpress, Bigtreetech is cheap and decent but the documentation is weak so takes a bit of finagling.

Note: Those are my own opinions, others may feel very different. I’ve used all those boards in the past. There are others but I haven’t tried them.

Apparently, you did not. The solution for exactly this problem is listed in the link I have posted.

Post a new klippy.log
In general, it is known that Duet boards are having issues on Debian based distros. There are reports that they do work under Ubuntu 23.10

Long story short, I was able to resolve this issue. I will post an update this afternoon if others stumble across this post.

My apologies for not including more information of everything I had tried, but I was mentally exhausted by the time I sought for help on here. No one would have had time to read through the steps I took for each of my attempts.

That being said, everything in your article is great, except none of it was able to resolve my issue. My specific issue was installing MainsailOS first each and everytime. The latest version was causing the USB port to stop being read.

Link to fix: Duet 2 firmware compilation broken on Debian 11 - #9 by lurifax

This is not something I do everyday, so the steps I had written down before (2 years ago) to get everything flashed were not working. The first step was to always install MainsailOS. This was apparently the root cause of my issues. Here are the steps I used in order to get this working on my setup.

NOTE: My EBB42 board had already been flashed with CanBoot prior, and the video I used is here

  1. With Raspberry PI imager I installed Raspberry Pi OS Lite (64-bit).
  2. I followed the steps and installed Kiuah with everything I needed for my setup, then rebooted: GitHub - dw-0/kiauh: Klipper Installation And Update Helper
  3. I shorted the reset pins on my board, then hit the reset button to wipe the firmware.
  4. I followed the steps in this guide from step 3 to get my board flashed without errors after flashing the troodon board (this was where I kept getting stalled at after flashing the board)
    Advanced-3D-Printing-Klipper-Kit-Installation-Guide-v0.1-2.pdf (1.3 MB)
  5. I think this next part is just for my EBB42 mcu. SSH’d to the Pi with Putty and ran:

sudo nano /etc/network/interfaces.d/can0

then pasted in and saved:

auto can0
iface can0 can static
    bitrate 250000
    up ifconfig $IFACE txqueuelen 128
  1. Then ran:

sudo nano /boot/firmware/config.txt

then pasted this at the bottom and saved:

  1. Then I had to flash my rpi mcu with makeconfig, and set it to Linux.

It took me about an hour to go through all that last night, but everything finally came online without any errors. Something in the latest MainsailOS was causing it to not read correctly from the USB port after flashing the board. Hopefully this will help point someone else in the correct direction. And I would appreciate feedback on this fix, and what I could have done differently.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.