Multiple hardware configurations, same errors (Got EOF when reading from device, Heater extruder not heating at expected rate, etc)

Basic Information:

Printer Model: Ender 3 heavily modified
MCU / Printerboard: Manta E3EZ, Manta M8P, EBB36, EBB42
Host / SBC: CB1 eMMC, CM4 eMMC
klippy.log

klippy.zip (252.1 KB)

Describe your issue:

Well, I am at the end of my knowledge, so I’m asking for help…

This problem occurs with multiple configurations. During the past two weeks I swapped any component that I could, the only common thing that remains is… the printer frame.

Shortly into print, 10-15 minutes, printing stops. klippy.log shows:
b'Got EOF when reading from device'
then

Heater extruder not heating at expected rate
Transition to shutdown state: Heater extruder not heating at expected rate

then, of course, the mcus shut down.

The problem is that I swapped a lot of components (I have them because sometime in the future I want to build another printer):

  • I have two boards, Manta E3EZ and Manta M8P
  • I have three host boards, CB1 eMMC 16GB, CB1 eMMC 32GB and CM4 eMMC
  • I have two toolboards, EBB36 and EBB42
  • I have two hotends, with different heaters and thermistors (NTK and PT1000)
  • I have two power supplies

For the past two weeks I tried every combination of those, with different OS versions. Communication tried trough CANbus (bridge mode or IO2CAN), USB, you name it. Exchanged every USB/CAN cable.
The current setup, from where the klippy.log is attached, runs on the MantaE3EZ USB connected to the CM4 running Raspberry Pi OS Lite 32 bit, and the EBB42 USB connected to board. But, as I said, the problem arises on any combination of the above.
I suppose that the first error message, Got EOF when reading from device, is the trigger for the others. But I don’t get smarter from it. Yes, there is a bytes_retransmit=9 in the log, but that’s coming up right after boot, and stays there.
All hosts, CB1 and CM4 are piggybacking the boards, there is not a cable running to exchange.
I am very open to suggestions, and I am willing to try anything you suggest. I became very proficient at exchanging components and flashing software :slight_smile:

Thank you.

From your log errors - it’s mostly connection issue with mcu EBBCan

when you are getting Got EOF when reading from device - usually that means that USB Device connection disappeared.

Try to monitor your system in separate terminal by executing command dmesg -Hw
It will launch dmesg in monitoring mode and will be producing new messages in real time when something is happening, most probably you will see there USB Disconnection message when issue is happening.

Thank you for your advice. It’s helpful, because I’m a linux noob. I will try that tomorrow.
It’s crazy because that happens with two sets of hosts and EBB’s.
For now, like I said, the EBB is connected as USB. Next I intend to switch back to CanBus, but this time using a shielded twisted pair - I tried two cables, but both were unshielded. I know, CanBus being a differential signal should work unshielded, but I will try it nevertheless.