New to klipper and having an issue

Hi, I have recently installed the klipper firmware on my anycubic Vyper. I am running mainsail on my raspberry Pi 3b, and I’m having a couple issues. First issue is, every print ends with the extruder stopped at the final point in the path that it takes to print the object and I get an error result in the web interface, and I have to turn off the printer wait a few seconds and then turn it on and re-home it, then re-calibrate the bed mesh profile. I have no clue where to start looking to fix this, although, I am not half bad computer savvy and I can easily figure out things once I’ve been instructed what and where to look to resolve issues. I understand there is a lot more involved in orchestrating a print than I initially figured, but so far, I’ve picked up quite a bit of understanding of the processes involved. If anyone can help me out with this issue, it’d be greatly appreciated, thanks!

Can you tell us what the error message is? Or better yet, can you post the klippy.log file? That would go a long way in helping to solve the issue.

Having said that, the first place I would be looking is in the END GCODE section of your slicer, it’s sounds like there is something left in there that is incompatible with your new klipper config. The incompatibility could be in the end gcode or the klipper config, but there is likely something in there that is mis-matched, like a move out of range etc

1 Like

And I think it kept saying in the console that there was a problem with m141, something about not recognizing the command, and in the printer config file, it showed that the M141 command was set to 50, whatever that means. and it had a problem with another command it didn’t recognize, G5.
Also, I’m trying to setup a webcam and having trouble with that. Thanks for your help!
1klippy.log (2.5 MB)

The command “M141 S50” sets the chamber temperature to be 50C. If you haven’t set up Klipper to recognise that you have a chamber heater/thermistor, it will throw an error. The command is likely in the END GCODE section of your slicer, just comment it out for now until you get your chamber config set up in the config file. That’s assuming that you have a chamber to start with, if not just delete the command.

The G5 command draws a b-spline, and I don’t think this is supported by Klipper. I can’t think why a slicer would issue a G5 (the slicer is slicing a mesh, and so only really uses straight lines), so I suspect that is also in your end gcode, just try commenting it out.

Having said all of that, I had a quick look at your log and it appears that neither of those commands caused Klipper to stop, it just ignored them and kept on going. I can’t tell exactly why, but it looks like the RPi is losing the connection to the MCU for some reason. This is often caused by a bad connection between the two, such as a poor quality USB cable. However, I’m just guessing as to the cause, and I couldn’t see any reason for it in the log file.

okay you mean to put a # at the start of those lines you suggested to comment out? and could the problem with the RPi be that im not using the power adapter that i got with the RPi? in the web interface there is usually an icon of the RPi and it says its undervoltaged or it was previously undervoltaged.

i am also having trouble with printing when it comes to parts of the print not starting in contact with the bed. anything with any significant overhang just doesnt print. in some cases it just adds a small flaw to the overall print and i just overlook it, but sometimes it will just trash the whole print and i get just a mess of random plastic strings.

oh and where do i find the END GCODE settings?

and how do i find out if i have a chamber heater/thermistor or not?

and im using the usb cable that came with the printer


I don’t know if that’s the cause or not, however if it is complaining about too low voltage, that’s definately something that needs addressing

What Slicer are you using? It sounds like you just need to turn on supports

In your Slicer

Is your printer inside a sealed, heated enclosure? Or is it sitting in the open?

I don’t think that’s a good enough reason to rule out the cable as being the culprit

I am using the slicer that came with the printer, ultimaker Cura 4.2.1

The printer is open, no case around it

I looked around in Cura but can’t find where I’d be able to edit the gcode instructions

If the printer is open and not in an enclosure (aka a chamber), then you can safely comment out the instructions for setting the chamber temp.

In Cura: Settings->Printers->Manage Printers. Select your printer, then click Machine Settings

Cool thank you so much for your help. Also I forgot to mention that when we got the printer, and I was unboxing it, I noticed the stepper motor at the back of the printer was loose, the bracket that held it in place must have gotten broken during the shipping. So we super glued it and it’s holding for now till anycubic sends the replacement part. And add to that, the fact that we have the printer sitting on our dining room table which is kinda shaky, so I’m chalking it up to that for the reason we are getting some defects in our prints. I’ll see if quality improves once we get it setup on a more stable table, and the new part comes in.
You have given me quite a bit of help so far, but would you be able to walk me through setting up a webcam through the RPi? That would be a big help.

Which front-end are you running? ie Fluidd, Mainsail, or Octoprint? I’ve only used a webcam with fluidd, but it was pretty much plug and play. Are you using a USB webcam, or a raspberry pi cam that plugs into the camera connector on the Pi?

The shaky table will definately affect your prints, it will result in ringing or ghosting. You can use Klipper’s resonance compensation to compensate for it somewhat, but you’ll get best results by reducing accelleration on the printer

5 posts were split to a new topic: Experience with damping printer feet - Effect on Quality?

I’m using mainsail, I tried to hook up this old usb camera to the RPi, but it didn’t just plug and play, and then when I shut the RPi down and tried to start it up the next day, it wouldn’t start until I unplugged the camera. So there might be something wrong with that camera, I have a couple others I have to dig up

Oh and this is the result of trying the ringing tower test, it looked like the example picture in the tutorial I was reading was in a waaaaay worse state than the result I got, so I didn’t think I needed to adjust anything, but I don’t really know, I was just guessing

Processing: 16465168743206933609641845776337.jpg…

The ringing on the example was repeated about 8 or 9 times I think, my result was 3 or 4 maybe.

Yep, you’re right, that looks pretty good. Much better than I could get on the shaky table :slight_smile:

Is there a reference somewhere where it has like all the default settings for klipper on the anycubic vyper, along with some default settings for Cura so I can return to some kind of base standard? I’ve messed around with the settings a few times to try some calibration prints to try and dial in and tweak the printer cause I was still getting some failed printings, and I have been sort of discovering when print supports are needed, and I don’t remember everything I’ve tweaked, and I want to be sure any fails I get going forward aren’t the settings I messed around with. I’m kinda at this point that when I get a failed print, I can’t be sure the exact reason it failed, and I’d like to be able to rule that out and make learning this a bit more streamlined. Thanks in advance!