Performing long-distance homing on a Delta machine occur the "stepper_X" register IFCNT

The operation is as follows.

  1. IFCNT occurs when G28 execution takes more than 1 second to end stop.
  2. If you manually turn on the end stop within 1 second after executing G28, homing will succeed.
  3. After successful homing, lower Z to near the bed with G0, and then succeed with homing with G28.
  4. After successful homing, if you turn off the motor with M84, move the head near the bed, and then execute G28, an IFCNT error will occur.
  5. Print is no problem.

Is this a klipper issue?

Firmware version: v0.9.1-763-g3a497d04
MKS GEN-L board, TMC2280

You should attach the full unmodified Klipper log file here. That contains more information that will help in troubleshooting.

If you run SET_STEPPER_ENABLE STEPPER=stepper_a, SET_STEPPER_ENABLE STEPPER=stepper_b, and SET_STEPPER_ENABLE STEPPER=stepper_c and wait a second or two prior to running G28, does the problem go away?


Thank you.

G28 succeeded with executing SET_STEPPER_ENABLE STEPPER = stepper_X without any problem, but when I executed G28 after M84, IFCNT occurred.

klippy.log (23.9 KB)

It is klippy.log when printing with PLA for about 50 minutes after executing stepper enable.
IFCNT occurs during homing after printing.
testprint_klippy.log (1.5 MB)

I read the following topic and tried it.

My config is as follows.
homing_speed: 60

kinematics: delta
max_velocity: 300
max_accel: 3000
max_z_velocity: 300

Even if I reduced the homing speed to 10, there was no change, but when I commented it out, I succeeded in homing very slowly.
#homing_speed: 60

Changing the velocity did not change it.
max_z_velocity: 150

Resolved in branch origin / work-schedcache-20210916.