Printer pausing after a few layers

Basic Information:

Printer Model: Longer LK5 Pro
MCU / Printerboard: bttech Pi
klippy.log (1.5 MB)

Describe your issue:

I installed Klipper a few prints ago and the first thing I printed was amazing. All I’ve done is adjust the bed and z-height when the machine has been off for a while. Now, I’m trying to print something fairly simple (Case for P4 64x32 LED RGB matrix with Adafruit Matrixportal by Lame_Dave - Thingiverse) and the printer keeps pausing. Now, I’m not talking about the hotend pause while it reads more data that can be solved by using virtual SD card. I mean it full on pauses and parks in the far corner. if I catch it quickly, I can hit resume and it will resume, but if not, I have to heat everything up, then home all 3 axes, then account for the now incorrect z offset and maybe I can get it to print without too many issues.

Today, I went through this 3 times on the same print before giving up and stopping it altogetrher. I can’t find anything in any logs that indicated the print being paused or where the pause command is coming from. I could really use some help here. I’m pretty new to klipper, but not Linux or 3d printing, so let me know if you want any tests or data from the system

Are you using KlipperScreen?

Yes. Why would that matter?

I think I have solved the mystery. Looks like the filament runout sensor, which is notoriously unreliable on this printer model, was enabled. Before Klipper, I just disabled it in gcode and had done with it. I didn’t realize it was re-enabled and there was no indicator on the screen of why the printer was paused.

Turned that sucker off, should be golden now.

Looks like you’ve got it sorted but just in case, some users have reported incidents of “ghost hands” with certain combinations of controller boards and displays, where phantom screen taps are registered:

If you continue to have issues, it’s worth ruling out the possibility that you’ve got “ghost hands” tapping the pause button.