My printer keeps pausing

My Ender 6 with fluiddpi and Klipper keeps pausing, but if I catch it in time, I can go to the UI on my phone or laptop and hit resume, and I just have a little blob to clean up. I thought it had something to do with my network going out randomly, but usually when I close my laptop or restart my phone, which is weird, but my laptop was open and my phone was still on when I tried 5 times to print a calibration cube. Please help.

Hardware:
Raspberry Pi 4b+
Ender 6 stock mainboard
Camera for Raspberry Pi

Software:
Dgus reloaded firmware for the T5UID1
Desyuuuu’s fork of Klipper - snapshot-210619-0-g069a34fd
Fluiddpi
Moonraker

Klippy.log

hi david,

maybe check the gcode if there is no weird PAUSE statement
also check console. i had a couple of times where in the console it statet that i wanted to extrude more than what is allowed.

i believe klipper doesnt native support the G code for pause but you can make a [gcode_macro ] in your printer.cfg.

i looked at your log and at the end

  1. Got EOF when reading from device

  2. Timeout with MCU ‘mcu’ (eventtime=36852.313792)

  3. Transition to shutdown state: Lost communication with MCU ‘mcu’

  4. Dumping gcode input 0 blocks

  5. gcode state: absolute_coord=True absolute_extrude=True base_position=[0.0, 0.0, 0.0, 0.0] last_position=[150.7, 137.0, 10.0, 0.0] homing_position=[0.0, 0.0, 0.0, 0.0] speed_factor=0.0166666666667 extrude_factor=1.0 speed=25.0

  6. Reactor garbage collection: (36841.592792114, 36716.228978856, 36305.964592693)

now i dont know if u powered down the controller board but it stated no communication.
if u have put the usb cable into a usb3.1 port (blue) it may sometimes causes weirdnes with usb2.0 devices. if you are running over usb try switching the cable to the black usb port on the pi

Last night, I tried to print a mount for a BIQU H2, and it “paused” 3 times in 8 minutes. Each time I heard a clicking sound just before it paused. I can’t be certain, because I can no longer localize sounds, after losing 100% of the hearing in my left ear a few years ago, but I think it may have been coming from the filament runout sensor. I disabled it in the klipper firmware, and it completed the 6 hour print, without another pause.

I did notice the clicking happening during the print, and sometimes the blue light would come on, on the filament runout sensor, and then go out.

I thought the filament runout sensor was purely mechanical, but apparently it’s not. If it is just the sensor, why is there no sign of a command, or anything sent to klipper that would show up in the logs? Does it just shut down the MCU directly, like cutting power to the printer would? Why do I only have a short window to resume? Maybe less than 5 minutes. The normal pause will send the tool head back to 260,260, but when this happens, it just pauses in place.

Do I have a bad sensor, or what could the issue be?

The sensor is definitely causing the issue, because on the next print it paused again, but it actually went to 260,260. I checked, and the runout sensor was enabled. I removed it from printer.cfg.

Now, there seems to be something wrong with my bed mesh…

@davidadrake did you find a solution to this? I’ve been trying to solve the same issue for days, and only turned up threads about Octoprint. I have (almost) the exact same setup as you- Ender 6, stock Creality board, Raspberry Pi 3B+, Fluidd.

I had custom firmware so I could use the Ender 6 screen, but I’ve reverted back to vanilla Klipper, and still have the issue! I have the problem whether I slice in PrusaSlicer or Cura, but the slicer does affect when and where the pause happens. For me, it always pauses at the same point in the print, and can be from 0-4 pauses per print.

UPDATE:

Well, I completely removed the filament sensor from my config, and that seems to have solved the issue. I still believe that it is a software problem, because the pauses were repeatable at the same points in each print. Very weird…