Printer prints in the air

Basic Information:

Printer Model: FLSun SUperRacer
MCU / Printerboard: SKR 1.3 clone
klippy.log (150.5 KB)

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

Just updated Klipper to current status. Verified good Z=0 by paper test, then repeated G1 Z0 to ensure printer knew where Z=0 is. First print started with nozzle about 25 mm up from printbed. After that G1 Z0 puts nozzle about 25 mm up from printbed.

Link to my printer.cfg: printer.cfg -

Printer.cfg has this line in the [probe] section:
#z_offset: 13.0
and this line in the ## [probe] section:
# z_offset = 0.010

I’ve tried doing PROBE_CALIBRATE, MANUAL_PROBE, Z_ENDSTOP_CALIBRATE, but none of them fix my problem.

You need to run DELTA_CALIBRATE to adjust Z0 on a delta. Since you don’t have a calibrated probe offset, I would suggest doing the manual method.

I did run DELTA_CALIBRATE prior to my latest update to the current Klipper version and I still had the same problem. But I’ll run it again now. I have also done both the auto and manual Z0 functions, but I’ll redo those also. Will post results later today.

Your suggest enabled me to solve my problem - sort of. This is the sequence of commands and events that led to a good solution:

Power on
Probe_CALIBRATE followed by manual Z0 adjustment
G1 Z50
G1 Z20
G1 Z5
G1 Z2
G1 Z0 <== Nozzle tip was maybe 0.5 mm above a good Z0 value
Manual Probe -0.01 eight times to get to a good paper test value
Start test print
Print started in mid-air about 30 mm above print bed

Since I think creating a bed mesh has something to do with how Klipper establishes the Z0 offset I deleted the mesh I had previously created (which looked quite good actually), and ran

Verified there was no stored mesh
verify new bed mesh was created ok
Start test print

This started printing very close to the printbed, but the nozzle was too high. I used the baby-step adjuster to get the nozzle down to a good printing elevation. Then I cancelled the print followed by a Save Z-Probe and SAVE_CONFIG just to be sure.

I appreciate your suggestion to do the DELTA_CALIBRATE command - I didn’t do that because I thought the delta calibration values (whatever they are) were stored in printer EEPROM (I used to use Marlin), but this is clearly incorrect. I do suggest the Klipper documentation for delta printers be updated to include the above command sequence so that other people don’t fall down the same rabbit hole I did.

Klipper has pretty extensive documentation on the proper way to calibrate a delta printer. It’s not clear to me that the method you used will result in accurate prints.

I’ve read that page several times. My point was it’s the entire sequence of events that allows the printer to work, and I think I’m not the only one who didn’t get an understanding of what the sequence needs to be. And as far as accuracy goes, this is good enough for me:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.