Reflashed klipper (ender v3 se) and now getting mcu error

Basic Information:

Printer Model: Ender 3 V3 SE
MCU / Printerboard: CR4NS200320C13
klippy.log
klippy (1).log (421.4 KB)

Describe your issue:

Hey all,

I’ve been running klipper on my ender v3 se for the past few weeks and its been amazing, but I havent been able to get my rpi camera to work, so I decided to rebuild klipper.

Now Im getting totally stuck on this mcu error and not sure how to resolve. I have already dropped baud rate to the proper level in config (which fixed this issue for me last time)

My only thought is that maybe my reflash is not taking on the printer, but Im not sure how to tell if that’s the case or not. Hoping someone could scan the klippy log and find the fix (Im a bit out of my league here!)

Thanks in advance!

Did you have a look here How-To Trouble-Shoot?

Good luck, hcet14

1 Like
  1. Reflash your board according to the relevant instructions
  2. Use the dmesg tool to check if your board registers properly in Linux
  3. Check ls /dev/serial/by-id/*

Hey @Sineos, appreciate the help. Still stuck though.

I have tried reflashing a couple times. Seems it may be fine based on your last two points?

When I run ls /dev/serial/by-id/*
I get /dev/serial/by-id/usb-1a86_USB_Serial-if00-port0

I have also attached the dmesg output, which seems to be fine (?)

Still getting that error on Mainsail, though. Goes on “waiting to connect” standby for a couple minutes before flipping to that mcu error referenced above.

Any idea of what I could do to troubleshoot next? I think hardware is otherwise fine. It was working perfectly fine yesterday before I rebuilt my RPI.

dmesg.txt (28.0 KB)

Yeah, I think something else weird is going on. Thanks hcet!

you have the serial wrong in the printer.cfg

[mcu]
serial = /dev/ttyUSB0
restart_method = command

additionally you flashed the board with the wrong baud rate:

CONFIG_SERIAL_BAUD=115200

Your rpi camera has absolutely nothing to do with Klipper, reflashing your board makes no sense

My understanding is that I can use either ttyUSB0 or the other serial. In any case, I have tried both and neither resolve the issue.

As for baud rate, this is a setting specific to this ender board. I ran into this problem when I set up klipper initially and changing it from 250000 to 115200 fixed the issue entirely. For sake of argument, I just tried it at 250000 again and returned the same result.

So, its still something else. Any other ideas?

Also btw, I know reflashing has nothing to do with the camera. I reflashed because my serial ports on my other rpi board were bad, so I bought a new one and rebuilt everything from scratch. Assumed I needed to reflash after that. Perhaps I did not?

JT

Flash again with following settings:

  • STM32F103
  • “28KiB bootloader”
  • serial (on USART1 PA10/PA9)
  • “Enable extra low-leverl configuration options” and “Disable SWD on startup”
  • copy klipper.bin to a SD rename it to something unique (not used before, only lowercase letters but ending in .bin)
  • turn on the printer with the card inserted

Remove all other devices from the RPi.

Hey @Sineos, thanks for this. Still not working. Posting new logs here, getting the same error. I also just started everything over from scratch, this time using the mainsail OS image for RPI (versus kiauh) and still getting the same result.

klippy (3).log (113.7 KB)

Sorry, cannot offer any more guidance.
Your error is a low level error of Linux that it cannot open your board as a serial device as it does not respond like expected.

This typically has two reasons:

  • First and foremost and board that is not correctly flashed
  • Wiring issues between board and SBC, e.g. bad USB cable

Some unsorted things to look at:

  • Different USB cables
  • Different SD cards for flashing (<8GB)
  • Potentially an issue with the bootloader of the board. As an alternative, flash katapult as bootloader

@huhen uses #baud: 500000 and the same printerboard.
I would give it a try…

Hey all,

Finally fixed this after a few weeks of frustration and tinkering. Actually spent about an hour ‘talking to’ chatgpt and one of its suggested resolutions was to check baud rate in printer.cfg.

I didn’t have it.

My thought is that the default baud rate is 250000, but the ender v3 se required 115200. Because of that, I think you have to explicitly set that under mcu settings in printer.cfg.

For anyone else facing this issue, heres what I added to my mcu settings in printer.cfg:

[mcu]
serial: /dev/serial/by-id/usb-1a86_USB_Serial-if00-port0
baud: 115200
#serial: /dev/ttyUSB0
restart_method: command

Hope this helps. Just wanted to tie a bow on all this chaos. Thanks all for the help :slight_smile: