SKR Pico - z stepper wont move

Basic Information:

Printer Model: Ender 3
MCU / Printerboard: SKR Pico
klippy(7).log (56.8 KB)

Describe your issue:

Hello. I am trying to get my skr pico to play ball with my ender 3. Everything else seems to be in order, except the z stepper motor wont move. When I home or buzz it makes one loud click/thunk then locks - I can hear the that the coils are energized. I have tried different cables and steppers. The same cable and stepper is fine on the other stepper ports.

homing times out with No trigger on z after full movement

I have a bunch of gstat reports in the klippy log:
TMC ‘stepper_z’ reports GSTAT: 00000001 reset=1(Reset)
TMC ‘stepper_z’ reports GSTAT: 00000000

The other steppers also report this, but work as expected.

Any clues? This is an unused, new board btw.

If I look through your printer.cfg I think your [tmc2209 stepper_z] statement should probably have the hold_current and stealthchop_threshold added and look like:

[tmc2209 stepper_z]
uart_pin = gpio9
tx_pin = gpio8
uart_address = 1
run_current = 0.580
hold_current: 0.500 
stealthchop_threshold: 999999

When I look at other people who have added the Pico to the Ender 3 they’ve also added a BL Touch so their settings are a bit different.

Hopefully adding the two statements to the [tmc2209 stepper_z] statement will fix your problem.

printer(4).cfg (2.4 KB)

Thanks for the tip. I tried that, but I still get the same issue. printer.cfg attached.

Maybe adjust the endstop to something other than zero to begin with.

Does your Ender 3 have dual Z motors or single?

Just a single Z motor

Just for reference, specifying hold_current is discouraged:

Prefer to not specify a hold_current

Personally, I’ve never seen artifacts from using hold_current, just pointing out that it is not recommended.

1 Like

What happens when you run QUERY_ENDSTOPS? Does the z endstop behave as expected?

yep, the endstops all behave as expected.

Interesting. I’ve used it for a while now on two printers to hold the Z axis height without any issues.

1 Like

Yeah, same here. it’s never caused me any issues that I have noticed

1 Like

This does not necessarily point to an issue. The TMC is resetting itself and immediately reports that everything is fine.
This happens if a user powers up the board before powering up motor power, or if the user disables and then reenables motor power while the board is idle. In these cases, when Klipper enables the stepper, it will see that there was a reset of the driver, clear the reset flag, verify that the reset was cleared, and then proceed normally.

If such a reset is immediately followed by some other errors, then it is problematic and a hard to debug TMC issue

Your configuration appears to be correct. If the issue follows the driver port, i.e. same stepper / cable works on a different port then it might just be a hardware issue with the board

The switching of currents was found to cause minor accuracy issues. Unlikely that it would be causing real world issues but since the effect of hold_current is also very minor (and the setting typically confuses users) the recommendation is to no longer use it.


Thanks for your help. It’d be a bit of a blow if it is a hardware fault with the board as this is the first time it’s been used and I bought it a year ago. Oh well. I guess I can get by with an old melzi board for now. It’s not my main printer at least.

Did you ever manage to figure this out? Got the same issue…

For the age of this thread, please open a new one in General Discussion with all requested information.

1 Like