Start end extrusion problems

I have a problem printing fast with a Ender 5 plus.
Start under extrusion and end over extrusion.
At speed 10 is all ok no gaps ! but presure advance not calibrate speed of work to give same result to all speed?

acceleration: 1000
print speed: 300
first layer: 10

The test of pressure advanced is not printed bad,all acceleration,extrusion controls is turning off and select distance of good print height to set .
pressure_advance = 0.64

klippy (11).log (1.0 MB)

any suggestion?

this is infill same problem

A standard Ender 5 is VERY FAR away from being capable of printing at 300mm/s.
Also it is generally the wrong direction your a heading: Most of the time, a high acceleration has a far bigger impact on the print times than the speed.

Thank you for reply,
i see video of fully stock E5P print 200mm/s.
I have changed heater ,hotend and thermistor i can print 300° now.
I don’t have a Rasberry i have atom 4 core cpu.
But you have any suggestion to set maximum speed and acceleration? because 80 or 300 is same problem.
Thank you for help.

Ok, i go little bit better now … not gaps but over extrusion at end ,end infill

You are over extruding everywhere not only at the infill.
Due to this fact and because of infill lines not being connected there is some excess of filament at the end of every infill line.
You can either properly dial in your printer and filament or trying to reduce infill overlap and infill flow.
And best practice is to get familiar with your printer on normal speeds like 60 mm/s and build a proper slicer profile.
If this works and you know what you are doing you can try going faster and adjust some parameters accordingly.

Thank You for reply,
yes at low speed i dont have problems.

Check your retraction settings. Based on the video, it looks and sounds like your retraction length is too high. Retraction speed might be too high as well. The print head is stopping and pausing after almost every move while the extruder retracts and then de-retracts the filament. The purpose of retraction is to relieve the static pressure of the filament to reduce oozing, but if you retract it too far or too fast (as appears to be the case here), it can cause gaps and air bubbles in the extruded filament exactly like what you’re reporting.

Also, the repeated lengthy pauses of the print head actually give occasion for more oozing and for the nozzle to melt the filament directly underneath it. Combined with the overextrusion, that’s why you’re seeing those round blobs everywhere the nozzle pauses.

After getting your extrusion rate corrected, calibrate pressure advance at no more than 100mm/s, then try to dial in retraction. On my Ender 3 I use a retraction length of 0.6mm and speed of 25mm/s. I have direct drive so on a bowden, the retraction length might need to be longer, but aim for as low as you can tolerate. Also turn on “wipe while retracting” or whatever your slicer calls it. That will reduce blobbing by preventing the hot nozzle from parking in one spot over the print while the retraction moves are happening.

Finally, for whatever it’s worth, your retraction settings are also slowing you down. Your video says the first layer was printed at 10mm/s while the others were at 300mm/s. Your first layer printed in about 4:31 but your second layer still took about 1:20 to print. Both layers look like they were about the same amount of plastic (perimeters and solid infill). The max print speed of the second layer was (nominally) 30 times faster than the first layer, yet actual print time wasn’t even 3.5 times faster.

Now look at the third layer. That’s single perimeters plus sparse infill, and it took about 0:40 to print. That’s only 3 times faster than the second layer, but from the looks of it, your sparse infill is much lower than 33%. Most (if not all) of that lost time is from those long retraction pauses.

1 Like

Thank you very much !!!
You are very help full and accurate!!
I go try now!

calibrate pressure advance at no more than 100mm/s? how to? in the config?

I would recommend to calibrate PA at your intended printing speed / acceleration or above. The value of 100 mm/s is chosen because you need this minimum speed to really show the effect of PA.

  1. Slice the test part at your intended speed
  2. Make sure to disable extrusion relevant “optimizations”, e.g. coasting, Pressure equalizer, dynamic acceleration whatever
  3. Min layer time or similar should be turned off for the tests as well

In general you need to take into account:

  • As stated above, low acceleration but high velocity is counterproductive in terms of print time
  • Pressure advance puts high strain on the extruder:
    • Bowden extruder are especially critical
    • The higher the PA, the higher the stress
    • The higher acceleration / velocity, the higher the stress on the extruder
  • If PA in combination with velocity / acceleration is too much for your extrusion system, quality will suffer greatly
  • Printing velocity and melting capacity of the hotend have a close relationship. If the combination of velocity, nozzle size and layer height (so called “Volumetric Speed”) is too much for your extruder, the quality will equally suffer greatly

0.4 nozzle with a line-width of 0.48mm and a layer-height of 0.2 and velocity of 300 mm/s will result in a volumetric speed of 28.8 mmÂł/s.
This already requires a very good extruder with a high flow hotend. And this is not even taking into account the additional stress caused by PA.

Thank you, today is coming a new stepper for make a direct extrusion.
Need a little bit of time to tuning the CNC with new switches STOP for make the bracket for mount the extruder.
In this days i have restarted the pressure advance test with 3 start values 0,0.50, 0.40 but the value of measure change all time i am not happy for that …