Underextrusion at line start

Basic Information:

Printer Model:
MCU / Printerboard: SKR 3
Host / SBC
klippy.log

Describe your issue:

Hi there,

I build a large printer and just exchanged the rapido uhf hothend for the VZBOT goliath hotend. The extruder is an orbiter 2 and I am using orca slicer. At first I was very satisfied but as soon as I tried out bigger nozzles as 0.6 and 0.8 I get serious underextrusion at almost every line start. I suspect it to be too little pressure in the hotend since it certainly appears after longer travel moves. I did flow, pa, and retraction calibration and nothing really makes a difference. While playing with settings during printing I can decrease the effect of underextrusion by setting retraction almost to 0 (0.1mm), adding Unretract Extra Length(1-3mm) and increasing pa to up to 0.1 which intruduces underextrusion at corners of course. But there will always still be a gap. Even with the Unretract Extra Length there will be a blob of the extra extrusion and then a gap before it starts extruding. I dont have any other artifacts nor issues and this drives me crazy for a few days now. I really tried out everything and hope someone here can help me.

Thanks
Vincent


klippy.zip (3.5 MB)

What print setting do you use ?
Acceleration, Print Speed, Move speed, layer height ?
Do you use firmware retraction ?
Do you use some Slicer advance move control features ?

For the print from the picture: 0.25 layer height, 0.6mm linewidth, 200mm/s speed and 10k acceleration. I tried with and without firmware retraction and tried out many different variations of retraction distance, speed and the same with unretraction. Nothing really makes a difference except setting a large unretract amount which causes overextrusion at parts where the seam is fine.

Setting seam position to nearest and travel speed high(400mm/s) the issue reduces slightly but is still significant.

If you mean pressure advance yes as mentioned in my original post.

What @gaolst was rather referring to: Do you use any slicer advanced move control in addition to Pressure Advance? Often slicers have functions like “Coasting”, “Dynamic Extrusion Blabla” or internal PA like functions. Combining them with Klipper’s integral PA function is a very bad idea because they will create a mess.

General notes on PA:

  • You seem to have it hardcoded. Be aware that PA is a filament property and should be tuned per filament, nozzle diameter, even extruder temperature
  • pressure_advance_smooth_time is a sensitive setting. Leave it default, especially if you are having issues.
  • As mentioned above, never combine PA with slicer’s inbuilt extrusion control mechanisms

I think you are trying to push your extruder too much.
0.6mm X 0.25mm X 200mm/s=30mm^3/s

and if I look at Orbiter 2 specifications - it’s already too much for it.


Also you are using PA - it should pre-charge your nozzle and it’s doing this even with higher rates than normal extrusion rate.

To exclude this you can try to reduce layer height or print speed by factor of 2.

Also I would suggest to decrease acceleration - when I was tuning PA for my Bowden extruder I did see huge impact on extruder motor behavior.

Generally very valid, but I’m not sure that it is a justified conclusion in this case.

As far as I understand these benchmarks they are a relative and not an absolute comparison, this means they always use the same hotend thus taking it out of the equation.
So, these numbers would have to be read in the sense of “with hotend XY the different models / designs compare like this”.

1 Like

Thanks for the answers so far!

I dont have anything like coasting enabled. I already recalibrated my pa for my 0.4 nozzle and petg filament.
FYI this issue has just shown up since I switched from the rapido uhf hotend to the goliath one. Forgot to say that I am using a direct drive system.
With the rapido everything was fine until I hit about 50mm^3/s.
With the goliath hotend I do pretty extreme printing in terms of flow now. Up to 60mm^3/s and it does everything perfectly except the start of a new line after a long travel move. I tried decreasing acceleration to 5000mm/s^2 and overall flow to about 20mm^3/s and it still persists. No matter how slow I print.
I printed a test model with line start after a long travel move. You can see how the filament is running out as soon as the travel move starts. This leads me to think that the hotend is capable of just too much flow and the filament is just running out as soon as your leaving the print or there is too much pressure caused by whatever? Not enough retraction distance? Printing temperature is 235°C with petg.

I feel like I need a function that increases the extrusion multiplier or prime amount for the first millimeters of a line start relative to the previous travel move or something similar.

Not sure. My Goliath is still lying around (since 6 months) and I did not test it yet.
Generally, I could imagine that it is a problematic hotend:

  1. Very long melting zone
  2. Retraction, regardless of the amount, can only retract solid filament but not molten one
  3. Gravity cannot be cheated
  4. Large nozzle diameters will allow more “free flow” of the molten filament

So it might just be a well-meant design that is badly defeated by reality. :person_shrugging:

Well that is what I have been afraid of. That the Goliath is good at delivering high flow but only that…

Wouldn’t it be possible to implement a function as I mentioned? Extrusion multiplier relative to previous travel move? This is really the only problem I have with that hotend. Im relying on high flow since I print big…

Honestly, no clue. Even not if it would bring the wanted effect.
That this hotend could be prone to oozing and hard to control retraction wise is one thing.
This starvation effect on the lines start is something totally different and I would think not related. No idea what it could be causing.

Can you share G-Code file ?

tank_PLA_4h4m.gcode (4.9 MB)

This is the one I had the biggest issues with since it is pretty large (400x400mm).

Any photos with issues which can be used to match g-codes to issues?
it’s hard to understand where you experience issues without visual reference.

tank_PLA_5h18m.gcode (6.5 MB)

Sorry, this is the Gcode with its printed model.

Just double checking you made sure everything in the extruder is tight, like the gearset and such? Loose stuff can cause some really strange problems!

Yes the extruder is fine.

Your issue is looking like backlash problem in your extruder.

Do double check of primary drive gear over the spider shaft, it could get loose.
Screenshot from Orbiter 2 assembly guide

P.S. I’m still analyzing your G-Code…

Thanks. Yes I already disassembled the extruder and tightened everything properly after this issue first occurred.

Hi
I did analyze your G-Code and isolated part of it which is probably is causing issues.
The model.

here are related G-Code with analysis

So as I can see by numbers - your G-Code is overloading your extruder on retract and unretract.

If you would also account for Pressure_advance - then your real rates will become even higher, because when unretract is happening PA additionally is trying to create huge pressure in the nozzle so it could extrude at that high rate and your stepper-motor is just skipping (it can’t handle such high speeds).

Try to decrease retract/un-retract speeds to 20-30mm/s or 1200-1800mm/m
this will reduce the rate to 48-72mm^3/s and then after the re-slicing - re-check G-Code if it’s actually reduced.

1 Like

Hi there. I had same problem described after everything was running well by long time.
The problem was some filament stuck on the nozzle and imside of heater block . Just heat it , disassemble, clean all, and ready to print again.
It was produced by a medium quality filament

1 Like