Start Print macro - Prime line stall/ooze & bed calibrate twice

Basic Information:

Printer Model: Elegoo Neptune 2S
MCU / Printerboard: ZNP Robin Nano V1.3
klippy.log (4.2 MB)

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
When pasting code or config snippets use the code tags </> in the menu above

Describe your issue:


First problem: At the end of the prime line it will wait for 30 secs to a minute, ooze a blob of filament and then go on to as normal. I’ve read it has something to do with not setting a specific temp and maybe the slicer inputs additional wait time to reach temp. Not sure what I would change though.

Second: Bed mesh calibrate, I’m running a calibrate print area only macro, however it will run a full mesh prior to starting temp, then another one for the print job area. If you could be kind enough to help me optimize my start macro that would be greatly appreciated.

printer(1).cfg (9.5 KB)