System load issue?

Basic Information:

Printer Model: CR10 knockoff (CREASEE CS30)
MCU / Printerboard: BTT SKR mini E3 V2.0 (1.2 MB)

Hello All,

I have been tracing an issue with this printer, and I think it might be something to do with system load on this cheap Le Potato (Raspberry pi 3 B+ “clone”).
Background: Was running this printer by itself on this Potato, and it worked great. This hobby being what it is I decided to upgrade the entire X carriage. Bought another printer (Anycubic Kobra Neo) installed Klipper on that and added a second instance of Klipper on the Potato. Never had an issue with the Neo on the Potato. Fast forward to having finished upgrading my CR10 knockoff. Connect the printer to the Potato, it connects, it moves, it does “all the printy things”. Test prints work good so I load up a huge multi day print and let it rip. After a night of sleep I check the progress of the print, and to my shock it stopped after about 5 inches of vertical travel. Now I was thinking at this point maybe there was to much system load because I was running both printers at the sametime. Attempted to run the print again without the second printer and camera disconnected. Same thing happened it stopped at about 5 inches up. I was lost at this point and thinking it was something else, I replaced the factory Makerbase MKS Robin Nano with a BTT SKR mini E3 V2. I was thinking maybe there was an issue with the Robin Nano board due to the fact that I accidentally shorted the part cooling fan pins when checking voltage on the pins. The MCU apparently isn’t the problem after a different print failed at around the same height. At this point I am scratching my head, and I am not sure why one printer will run 100% fine with no issue but the other one just stops after some time, and they are not printing at the same time for this to happen. I humbly ask for some guidance.

Your log contains quite some errors, some critical, some not:

  • Multiple Unknown command (uncritical but still means you are feeding erroneous commands)
  • Move out of range: 235.140 174.063 97.050 [20600.913] (which I believe killed your print) → Move out of range: X Y Z [E]
  • Transition to shutdown state: Unable to read tmc uart 'stepper_x' register DRV_STATUS → Only once, seems not an issue
  • Transition to shutdown state: Lost communication with MCU 'mcu'Timeout with MCU / Lost communication with MCU

With a 16MB log and various errors it is kind of hard to say which one is spoiling your fun.

I really appreciate your response. I think my best course of action might be just starting from the ground up, and rebuild everything on the software side giving the printer its own pi and getting rid of the other errors in the gcode (I know that issues has been there since day one but was to lazy to fix it; cause it worked.).