Unable to succesfully use Klipper on PC

Basic Information:

Printer Model: Ender 3 Neo
MCU / Printerboard: V4.2.2 GD32F303RET6
klippy.log (107.1 KB)

I do not have a RPi, so I used KIAUH and my Ubuntu 22.04.04 LTS Desktop laptop to use it instead of the RPi and connect it to my Ender 3 Neo printer. In the KIAUH, I have 3 options to select from [Get MCU ID], 1) USB, 2) UART, 3) USB (DFU mode) instead of 2 as I usually see from other posts.

When I select 1 and 3 I get the “No MCU found! MCU either not connected or not detected!”
When I select 2 I get MCU #1: /dev/ttyS0.

I do not have folder /dev/serial/. I checked if I had CH340 drivers, as my board has on it the chip CH340G. I found that ch340 drivers are probably corrupted, so I installed them through this GitHub GitHub - juliagoda/CH341SER: CH341SER driver with fixed bug and following also, some of the check points used by this YouTuber https://www.youtube.com/watch?v=Y2mvdlnqRzA. I tried previously the newer version but did not work…
I also have the latest version of Kernels.

The printer can be seen with lsusb as “Bus 002 Device 015: ID 1a86:7523 QinHeng Electronics CH340 serial converter” and I have masked and stopped brltty. Also at dmseg.txt I can see the printer as “udevadm info --attribute-walk /dev/pci0000:00/0000:00:14.0/usb2/2-1/2-1:1.0/tty/ttyCH341USB0”. However, the Manufacturer is not Klipper… I attach also the dmseg.txt.

I don’t know what to do, or what is wrong. I used many different bin files for flashing the printer. Always with Baudrate at 115200 as the Creality gave me at the supplementary files in the SD and

Micro-controller Architecture (STMicroelectronics STM32) —>
Processor model (STM32F103) —>
Only 10KiB of RAM (for rare stm32f103x6 variant)
Disable SWD at startup (for GigaDevice stm32f103 clones)
Bootloader offset (28KiB bootloader) —>
Clock Reference (8 MHz crystal) —>
Communication interface (Serial (on USART1 PA10/PA9)).

I have also tried the default Baudrate 250000 and USART3 PA11/PA10 and all the combinations.
I have fully uninstall and reinstall all the package for KIAUH and Klipper etc, but nothing works.

If anyone can help, please reply. Thank you!

dmesg.txt (198.2 KB)


.

It sounds like your board hasn’t been properly flashed. Maybe this will help with your particular board: Support for new Creality boards 4.2.2 with GD32F303 - #54 by vecktor

1 Like

Work through Issues flashing the printer board and especially mind the chapter Linux Issues WRT Modemmanger / BRLtty

1 Like

Thank you @theophile for your answer! It works but unfortunately only when safe boot is turned of, because the CH340 drivers were unsigned. I try to sign them so to solve the problem. I tried openssl and creat a signature, but I cannot find a way to sign the already uploaded ch340.
Do you have any idea how to do so?

Thank you @Sineos for the guidelines, I found also some other things about Ubuntu, that I was suspecting but I wasn’t sure. As I wrote to @theophile the connection is achieved only when safe boot is turned off. I have created the cert.pem, csr.pem and key,pem through openssl. Do you know how to sign the already loaded CH340 drivers, so that I could use Klipper in safe boot?

I’m not sure what steps you followed but the Linux kernel has had CH340 support for a long time so there should be no need for using unsigned or out-of-tree drivers.

Okay… I read some posts online that claimed that CH340 drivers were corrupted. So I probably caused an additional problem to myself… I will try to find a way to remove the CH340 drivers I added. I will do so, and if it works afterwards I will mark the issue Solved.
Thank you @theophile !

@theophile indeed Linux kernel has CH340. My old Ubuntu had corrupted CH340 drivers, this is why Klipper didn’t connect without the out-of-tree drivers. I reinstalled Ubuntu from the beginning and the problem is solved! Thank you for the help!