Vocore with RPi3 and Fluidd+klipperscreen

Tried to follow the guide by @ichbaum , but I get stuck at
‘make -C /usr/src/linux-headers-$(uname -r ) M=$PWD modules’
command returns “no such file or directory” on my side. Is there something I’m missing in there?

Did you restart after updating?

No, I don’t believe I did. I’ll try again tomorrow, thanks!

Tried now but the error text is the same.

pi@fluiddpi:/tmp $ make -C /usr/src/linux-headers-$(uname -r ) M=$PWD modules make: *** /usr/src/linux-headers-5.10.63-v7+: No such file or directory. Stop.

Try cd /usr/src/linux-headers-$(uname -r )
to check if the folder exists.
The git hub download needs to be redone after a reboot. /tmp is erased after each boot.

Downloaded git again, but I get this:

-bash: cd: /usr/src/linux-headers-5.10.63-v7+: No such file or directory

Can you please have a look into /usr/src which Kernel you have?

I’m very new to linux so not quite sure how it’s supposed to look.
Klipper is running so something is right at least :slight_smile:

This is from src:


And putty:


Edit: Thanks for taking the time by the way, I appreciate it!

Nothing in /src …
Did you installed the headers?
sudo apt install raspberrypi-kernel-headers

For some reason, that had not happened. That did the trick! Now the screen is at least showing the terminal. Klipperscreen is not running yet.

1 Like

So, I’m pasting away relentlessly. Like I wrote, I can set the screen to black, random pixels and terminal window but then I run sudo FRAMEBUFFER=/dev/fb1 startx
I get this:

(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Fatal server error:
(EE) no screens found(EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) Server terminated with error (1). Closing log file.

And later some of this:

[   588.706] (WW) Warning, couldn't open module fbdev
[   588.706] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   588.706] (EE) No drivers available.
[   588.706] (EE) 
Fatal server error:
[   588.706] (EE) no screens found(EE) 
[   588.706] (EE) 

I’m in way above my head here, if you can see anything obvious maybe you can push me in the right direction. :slight_smile:

Lost connection with moonraker last night, so had to do a clean install of klipper.
Did everything here again but I get stuck on the same place when running sudo FRAMEBUFFER=/dev/fb1 startx

That is as far as I can come after all installations

@ichbaum , I had to add this to the code in order for the screen to start:

sudo apt install xserver-xorg-video-fbdev

Thanks to alfrix on Discord for spotting it.

Maybe the guide should be updated and corrected with your additions too. It is a great little screen!

1 Like

Sorry for the late answer. Somehow I don’t see the updates on this topic. May be I’m tonold for discord :laughing:.

I will post an update when I’m back at my PC.
I have the fbdev install in my newest script. It wasn’t necessary at first. I think something changed in the raspian version.

#Update system and kernel
sudo apt-get update
sudo apt-get upgrade -y
sudo apt-get full-upgrade -y
sudo apt-get clean
sudo apt-get autoremove -y
sudo reboot

#install kernel-headers
sudo apt install raspberrypi-kernel-headers
sudo reboot

#get vocore 
cd /tmp
wget https://github.com/Vonger/vocore2/archive/refs/heads/master.zip
unzip master.zip
cd /tmp/vocore2-master/utils/fbusb/src
#make vocore driver
make -C /usr/src/linux-headers-$(uname -r ) M=$PWD modules
sudo insmod fbusb.ko
sudo cp fbusb.ko /lib/modules/$(uname -r)/kernel/drivers/

#Load driver at startup
sudo /sbin/depmod -a

#1. set screen to black: 
sudo dd if=/dev/zero of=/dev/fb1 bs=1000 count=768

#2. set screen to random pixel: 
sudo dd if=/dev/urandom of=/dev/fb1 bs=1000 count=768

#Set Console output to LCD
#add "fbcon=map:10 fbcon=rotate 1" to cmdline.txt
sudo nano /boot/cmdline.txt

#Test console
export FRAMEBUFFER=/dev/fb1
sudo FRAMEBUFFER=/dev/fb1 startx

# install xorg driver
sudo apt-get install xserver-xorg-video-fbdev

#KlipperScreen Installation
cd ~/
git clone https://github.com/jordanruthe/KlipperScreen.git
cd ~/KlipperScreen

#remove fbturbo and use fbdev
sudo rm /usr/share/X11/xorg.conf.d/99-fbturbo.conf

sudo nano /usr/share/X11/xorg.conf.d/99-fbdev.conf
#Add this text ans save
Section "Device"
	Identifier "LCD"
	Driver "fbdev"
	Option "fbdev" "/dev/fb1"
	Option "Rotate" "CW"
	Option "SwapbuffersWait" "true"

#Rotate the touch input too
sudo nano /etc/udev/rules.d/51-touchscreen.rules
#add to file
ACTION=="add", ATTRS{name}=="VoCore Touch", ENV{LIBINPUT_CALIBRATION_MATRIX}="0 1 0 -1 0 1 0 0 1"

#In the KlipperScreen documentation is this metioned to test the touch rotation.
DISPLAY=:0 xinput set-prop "VoCore Touch" 'Coordinate Transformation Matrix' 0 1 0 -1 0 1 0 0 1
#But the /51-touchscreen.rules changes the 'libinput Calibration Matrix' and not 'Coordinate Transformation Matrix'.
#but you can test the 'libinput Calibration Matrix' as well.
DISPLAY=:0 xinput set-prop "VoCore Touch" 'libinput Calibration Matrix' 0 1 0 -1 0 1 0 0 1