Z Offset Not Being Applied

I have tried everything i can find online but can not get z-offset to work. I run probe calibrate and get offset of about -1.35, accept, save config but when it goes to print it doesnt use this. if i can adjust z down as it starts i can still print but very annoying. my printer config is attached. i also attached screenshot that shows fluid homescreen reporting z offset of 0 even though i have one set. Appreciate the help!

printer.cfg (7.1 KB)

I am new to this, but did you try the command?
SET_GCODE_OFFSET [X=<pos>|X_ADJUST=<adjust>] [Y=<pos>|Y_ADJUST=<adjust>] [Z=<pos>|Z_ADJUST=<adjust>] [MOVE=1 [MOVE_SPEED=<speed>]] : Set a positional offset to apply to future G-Code commands. This is commonly used to virtually change the Z bed offset or to set nozzle XY offsets when switching extruders. For example, if “SET_GCODE_OFFSET Z=0.2” is sent, then future G-Code moves will have 0.2mm added to their Z height. If the X_ADJUST style parameters are used, then the adjustment will be added to any existing offset (eg, “SET_GCODE_OFFSET Z=-0.2” followed by “SET_GCODE_OFFSET Z_ADJUST=0.3” would result in a total Z offset of 0.1). If “MOVE=1” is specified then a toolhead move will be issued to apply the given offset (otherwise the offset will take effect on the next absolute G-Code move that specifies the given axis). If “MOVE_SPEED” is specified then the toolhead move will be performed with the given speed (in mm/s);

Z_offset for a bltouch can’t be a negative number if you’re homing over the bed. The z_offset represents the distance between the nozzle and the bed when the bltouch triggers, so it will always be a positive number.

In the config you posted I see you’ve manually entered a value of -1.35 in the bltouch section, and you now have multiple different save_config sections with values of 1.233 and 1.327. You also have 2 different default meshes defined. It looks like you generated a save_config section, then added more stuff after the save_config, created another save_config section, added more stuff, and so on. As noted at the top of the save_confg section, you shouldn’t edit anything below it. If you need to add something to your config, add it above the save_config section, not after. At this point you’re going need to do a lot of cleanup to fix all of this. I would suggest deleting all of the save_config sections and starting over on your PID, probe offset, and bed_mesh.

1 Like

Also to clarify, the Z offset reported by Fluidd is not your probe offset. That is a separate g-code offset used to make micro-adjustments to nozzle height similar to baby steps in Marlin.

1 Like

Cleaned it up as suggested and got it working. Appreciate the help. Thanks!