BLTouch failed to verify sensor state

Basic Information:

Printer Model: Ender 3 Pro
MCU / Printerboard: Raspberry Pi 4 / Creality Mainboard V4.2.2
klippy.log: (compressed)

Describe your issue:

I have an Ender 3 Pro with Klipper installed and a BLTouch.
Since I replaced my hotend with the Sprite Extruder Pro the BLTouch fails to deploy quite often. In some cases I actually do not get the verify state error, instead the hotend moves towards the print bed without the probe deployed. This actually ended damaging 3 print beds.
First I thought of a hardware problem - like a cable not put in fully - but I couldn’t find anything obvious and after a few times, I noticed that the error mostly occurred after a print (whether failed/successful). At first start after a power outage it would work fine but when the problem occurs once it consists until I kill the power.
Recently I tested the BLTOUCH_DEBUG command after the error had occured (without restarting) and was surprised that every command was successful - the probe deployed and raised fine. However - even after a successful test by the debug command - homing was still not working with the same error.
I am pretty sure there must a problem with the software side but I don’t know much background of Klipper.

Any help would be appreciated since I don’t like the idea of damaging another print bed. Thanks

I’m pretty sure there isn’t. Likely thousands of Enders are running with Klipper and this combination, so if it would be a systematic issue then this and other places would be full of similar complaints.

BLTouches are sensitive like hell. I do not know how many of these buggers (at least 5) I have already replaced on my printers and how many times I needed to troubleshoot similar behaviors.
Mostly after doing some work on the printer, and often because of me being quite careless.

Thanks for the answer. Do you have any idea what might be the problem?

I tried much more stuff and noticed the folowing:

  • The problem occurs always when the print is cancelled (manually or caused by an error).
  • I use a custom macro for cancelling, however the problem occurs also when I execute the base command (CANCEL_PRINT_BASE) so the problem is within the cancellation itself.
  • The problem must lie on the Creality Mainboard itself since I tried killing power to the boards individual (disconnecting the USB-Cable from Raspi to Printer). Results: only when the Mainboard itself is powered down the issue disappears.
  • An emergency stop does not result in the issue. It’s just cancelling.

As the problem disappears when resetting the Mainboard, it indeed doesn’t seem like a software problem.

What could I try to understand the issue? I guess next thing is to try unplugging the Sprite Extruder Pro to see whether the issue is on its board and that’s the component I changed when the issue began. I’ll do that after my currently running print.

Hey! I’m having the exact same issue. I upgraded my Ender 3 Max to have the Sprite Pro extruder, and just like you I went from a reliable CR-Touch sensor to having to power cycle the mainboard after I do anything with it. Just wanted to say that I’m having the same issue lol, you’re not the only one

good to hear I’m not the only one with this problem.
This would indicate, that there must be a problem on the Sprite Extruder Pro board. I guess using the original cable from the probe to the board, omitting the Sprite Extruder Pro for the probe completely might solve the problem at least if the Sprite Extruder Pro isn’t putting a fault on the mainboard. However this is not a real fix.

I still wonder, why the BLTOUCH_DEBUG command is still working to lower and raise the probe, I expected this command to fail for such a hardware issue.
Does this command work also for you?

Just out of interest, did you also have the failure that the controller falsly verified the probe to be lowered (so the hotend moved down without the probe deployed)?
For me I think, an unreliable BL-Touch probably would be quite annoying but I could get away with it as long as it doesn’t damage the printer occasionally.

Yep, the BLTOUCH_DEBUG commands also seem to work just fine. For experimentation, I pulled the cable out of the little duct I’d routed it in, and for good measure also flipped which end was which. I’ll report how that goes, but so far it seems to be better. I’m not sure if I’ve seen that second failure you mention, but I’ll keep a look out for it.

I’m having the same issue after upgrading to the Sprite Extruder Pro. After a print (failed or successful) it errors with the same can’t verify sensor state. After power cycling the mainboard, you can print without the error.

I have three CR Touches laying around or in use. I disassembled the installed one and cleaned the probe with alcohol just to see what happens (I wouldn’t recommend doing that - it no longer works). I tried the second probe the same issue occurred. I stole the third from my CR-10 which is almost brand new, and the issue still occurs.

Flipping the short wires that come with the new extruder didn’t make any difference. I also tried testing continuity from each pin and it seems fine.

Comparing my previous printer.cfg file, I don’t see any differences at least in regards to the Z stepper and BL Touch sections (aside from the new offsets and I changed the safe home location).

I’m glad I’m not the only one having the issue. My next thought is maybe using the long CR touch wire harness and skipping plugging it in at the extruder and running it back to the mainboard.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.